summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-01-26 02:07:51 +0000
committerVlastimil Babka <caster@gentoo.org>2007-01-26 02:07:51 +0000
commited69ae65e05d1b58feb17f0b15a93b11be963750 (patch)
tree6337163bd5d498a373fb23c581a93ec8385a3afa /www-servers
parent- mark 5.4 stable on amd64 per kingtaco bug #163094 (diff)
downloadgentoo-2-ed69ae65e05d1b58feb17f0b15a93b11be963750.tar.gz
gentoo-2-ed69ae65e05d1b58feb17f0b15a93b11be963750.tar.bz2
gentoo-2-ed69ae65e05d1b58feb17f0b15a93b11be963750.zip
Make compatible with split-ant - was breaking with admin flag because there was a different servletapi slot on ant's classpath without specifying only the needed tasks. Older ant versions are not affected by this change.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog8
-rw-r--r--www-servers/tomcat/tomcat-5.5.20-r7.ebuild6
-rw-r--r--www-servers/tomcat/tomcat-5.5.20-r8.ebuild6
3 files changed, 13 insertions, 7 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 6a594869f655..6a57f7246450 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/tomcat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.105 2007/01/20 16:54:57 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.106 2007/01/26 02:07:50 caster Exp $
+
+ 26 Jan 2007; Vlastimil Babka <caster@gentoo.org> tomcat-5.5.20-r7.ebuild,
+ tomcat-5.5.20-r8.ebuild:
+ Make compatible with split-ant - was breaking with admin flag because there
+ was a different servletapi slot on ant's classpath without specifying only
+ the needed tasks. Older ant versions are not affected by this change.
*tomcat-6.0.8_alpha (20 Jan 2007)
*tomcat-6.0.7_beta-r3 (20 Jan 2007)
diff --git a/www-servers/tomcat/tomcat-5.5.20-r7.ebuild b/www-servers/tomcat/tomcat-5.5.20-r7.ebuild
index ed251b315946..616e5356f540 100644
--- a/www-servers/tomcat/tomcat-5.5.20-r7.ebuild
+++ b/www-servers/tomcat/tomcat-5.5.20-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.20-r7.ebuild,v 1.2 2007/01/10 21:06:33 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.20-r7.ebuild,v 1.3 2007/01/26 02:07:51 caster Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -163,8 +163,8 @@ src_compile(){
antflags="${antflags} -Dxml-apis.jar=$(java-pkg_getjar xml-commons-external-1.3 xml-apis.jar)"
fi
- eant ${antflags}
-
+ # prevent classpath bloat with ant-1.7.0 which makes admin app fail
+ ANT_TASKS="ant-trax" eant ${antflags}
}
src_install() {
diff --git a/www-servers/tomcat/tomcat-5.5.20-r8.ebuild b/www-servers/tomcat/tomcat-5.5.20-r8.ebuild
index 003cfd5585b3..8656bc6e57b8 100644
--- a/www-servers/tomcat/tomcat-5.5.20-r8.ebuild
+++ b/www-servers/tomcat/tomcat-5.5.20-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.20-r8.ebuild,v 1.1 2007/01/10 21:06:33 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.20-r8.ebuild,v 1.2 2007/01/26 02:07:51 caster Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -158,8 +158,8 @@ src_compile(){
antflags="${antflags} -Dxml-apis.jar=$(java-pkg_getjar xml-commons-external-1.3 xml-apis.jar)"
fi
- eant ${antflags}
-
+ # prevent classpath bloat with ant-1.7.0 which makes admin app fail
+ ANT_TASKS="ant-trax" eant ${antflags}
}
src_install() {