summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:42:57 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:42:57 +0000
commit6652831b6953c27692e79d9407965bfefc7d8358 (patch)
tree9a4d4a6c7d1753f06122a40ae325c60e140b55a1 /x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild
parentVersion bump. Adds an extra check that avoids a memory leak and NULL (diff)
downloadgentoo-2-6652831b6953c27692e79d9407965bfefc7d8358.tar.gz
gentoo-2-6652831b6953c27692e79d9407965bfefc7d8358.tar.bz2
gentoo-2-6652831b6953c27692e79d9407965bfefc7d8358.zip
Version bump. Fixes the 'have-no-file' test.
(Portage version: 2.1_pre10)
Diffstat (limited to 'x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild')
-rw-r--r--x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild b/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild
new file mode 100644
index 000000000000..72c2b1748ffd
--- /dev/null
+++ b/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild,v 1.1 2006/04/29 16:42:57 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib
+
+DESCRIPTION="X.Org xkbcomp application"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RDEPEND="x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ x-modular_src_install
+
+ dodir usr/share/X11/xkb
+ dosym ../../../bin/xkbcomp /usr/share/X11/xkb/xkbcomp
+
+ # (#122214) We should create this directory here, since xkeyboard-config
+ # and any other set of layouts will symlink to it.
+ dodir /var/lib/xkb
+}