summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild')
-rw-r--r--x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild b/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild
new file mode 100644
index 000000000000..72c2b1748ffd
--- /dev/null
+++ b/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbcomp/xkbcomp-1.0.2.ebuild,v 1.1 2006/04/29 16:42:57 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib
+
+DESCRIPTION="X.Org xkbcomp application"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RDEPEND="x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ x-modular_src_install
+
+ dodir usr/share/X11/xkb
+ dosym ../../../bin/xkbcomp /usr/share/X11/xkb/xkbcomp
+
+ # (#122214) We should create this directory here, since xkeyboard-config
+ # and any other set of layouts will symlink to it.
+ dodir /var/lib/xkb
+}