summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash/bash-3.1_p17.ebuild10
-rw-r--r--app-shells/bash/files/bashrc3
2 files changed, 6 insertions, 7 deletions
diff --git a/app-shells/bash/bash-3.1_p17.ebuild b/app-shells/bash/bash-3.1_p17.ebuild
index 09738e52624a..e874c380b239 100644
--- a/app-shells/bash/bash-3.1_p17.ebuild
+++ b/app-shells/bash/bash-3.1_p17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.4 2006/08/02 16:17:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.5 2006/08/02 18:22:15 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -126,12 +126,8 @@ src_install() {
newins "${FILESDIR}"/dot-${f} .${f}
done
- if use userland_GNU ; then
- sed -i -e 's:^#GNU#@::' "${D}"/etc/skel/.bashrc
- elif use userland_BSD ; then
- sed -i -e 's:^#BSD#@::' "${D}"/etc/skel/.bashrc
- fi
- sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc
+ sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+ sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
doman doc/*.1
dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
diff --git a/app-shells/bash/files/bashrc b/app-shells/bash/files/bashrc
index 3350e3dcbdc7..dedbbf5e5a99 100644
--- a/app-shells/bash/files/bashrc
+++ b/app-shells/bash/files/bashrc
@@ -45,6 +45,9 @@ if ${use_color} ; then
else
PS1='\[\033[01;32m\]\u@\h\[\033[01;34m\] \w \$\[\033[00m\] '
fi
+
+ #GNU#@alias ls='ls --color=auto'
+ alias grep='grep --colour=auto'
else
if [[ ${EUID} == 0 ]] ; then
# show root@ when we don't have colors