summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-3.1_p17.ebuild')
-rw-r--r--app-shells/bash/bash-3.1_p17.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-shells/bash/bash-3.1_p17.ebuild b/app-shells/bash/bash-3.1_p17.ebuild
index 09738e52624a..e874c380b239 100644
--- a/app-shells/bash/bash-3.1_p17.ebuild
+++ b/app-shells/bash/bash-3.1_p17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.4 2006/08/02 16:17:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.5 2006/08/02 18:22:15 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -126,12 +126,8 @@ src_install() {
newins "${FILESDIR}"/dot-${f} .${f}
done
- if use userland_GNU ; then
- sed -i -e 's:^#GNU#@::' "${D}"/etc/skel/.bashrc
- elif use userland_BSD ; then
- sed -i -e 's:^#BSD#@::' "${D}"/etc/skel/.bashrc
- fi
- sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc
+ sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+ sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
doman doc/*.1
dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO