summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild27
-rw-r--r--app-accessibility/brltty/brltty-3.4.1.ebuild19
-rw-r--r--app-accessibility/brltty/brltty-3.5.0_pre3.ebuild18
-rw-r--r--app-accessibility/brltty/brltty-3.5.ebuild18
-rw-r--r--app-accessibility/flite/flite-1.2-r1.ebuild14
-rw-r--r--app-accessibility/flite/flite-1.2.ebuild14
6 files changed, 48 insertions, 62 deletions
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
index 1c3b37f51a2b..899c4a60be8b 100644
--- a/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
+++ b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
@@ -1,44 +1,37 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild,v 1.4 2004/06/24 21:25:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild,v 1.5 2004/06/25 15:53:10 vapier Exp $
inherit eutils
-S=${WORKDIR}/${PN}
-DESCRIPTION="SphinxTrain - Speech Recognition (Training Module)"
+DESCRIPTION="Speech Recognition (Training Module)"
HOMEPAGE="http://www.speech.cs.cmu.edu/SphinxTrain/"
SRC_URI="http://www.speech.cs.cmu.edu/${PN}/${P}-beta.tar.gz"
-SLOT="0"
+
LICENSE="BSD as-is"
+SLOT="0"
KEYWORDS="x86 ~ppc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-accessibility/sphinx2
app-accessibility/festival"
+S=${WORKDIR}/${PN}
+
src_unpack() {
unpack ${A}
cd ${S}
-
epatch ${FILESDIR}/gcc.patch
}
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- dodoc etc/*cfg
- dobin bin.*/*
- dodoc README
+src_install() {
+ dobin bin.*/* || die
+ dodoc README etc/*cfg
dohtml doc/*[txt html sgml]
}
pkg_postinst() {
- einfo
einfo "Detailed usage and training instructions can be found at"
einfo "http://www.speech.cs.cmu.edu/SphinxTrain/"
- einfo
}
diff --git a/app-accessibility/brltty/brltty-3.4.1.ebuild b/app-accessibility/brltty/brltty-3.4.1.ebuild
index 15f1fa43a879..5120d797f51e 100644
--- a/app-accessibility/brltty/brltty-3.4.1.ebuild
+++ b/app-accessibility/brltty/brltty-3.4.1.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.4.1.ebuild,v 1.8 2004/06/24 21:17:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.4.1.ebuild,v 1.9 2004/06/25 15:55:35 vapier Exp $
-IUSE="gpm"
-
-DESCRIPTION="BRLTTY is a background process (daemon) which provides access to the Linux/Unix console (when in text mode) for a blind person "
-HOMEPAGE="http://mielke.cc/brltty"
+DESCRIPTION="daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha hppa ~mips amd64 ~ia64 ~ppc64"
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ~ia64 ~ppc64"
+IUSE="gpm"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
gpm? ( >=sys-libs/gpm-1.20 )"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -23,8 +21,7 @@ src_unpack() {
}
src_compile() {
- econf \
- `use_enable gpm` || die
+ econf `use_enable gpm` || die
make || die
}
diff --git a/app-accessibility/brltty/brltty-3.5.0_pre3.ebuild b/app-accessibility/brltty/brltty-3.5.0_pre3.ebuild
index 79eb8c195dd3..2f0525bd923c 100644
--- a/app-accessibility/brltty/brltty-3.5.0_pre3.ebuild
+++ b/app-accessibility/brltty/brltty-3.5.0_pre3.ebuild
@@ -1,26 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.5.0_pre3.ebuild,v 1.2 2004/06/24 21:17:18 agriffis Exp $
-
-IUSE="gpm"
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.5.0_pre3.ebuild,v 1.3 2004/06/25 15:55:35 vapier Exp $
MY_P=${P/.0_/}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="BRLTTY is a background process (daemon) which provides access to the Linux/Unix console (when in text mode) for a blind person "
-HOMEPAGE="http://mielke.cc/brltty"
+DESCRIPTION="daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
SRC_URI="http://mielke.cc/brltty/releases/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ~ppc64"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64"
+IUSE="gpm"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
gpm? ( >=sys-libs/gpm-1.20 )"
src_compile() {
- econf \
- `use_enable gpm` || die
+ econf `use_enable gpm` || die
make || die
}
diff --git a/app-accessibility/brltty/brltty-3.5.ebuild b/app-accessibility/brltty/brltty-3.5.ebuild
index d9a05170c169..d56c9d1bacae 100644
--- a/app-accessibility/brltty/brltty-3.5.ebuild
+++ b/app-accessibility/brltty/brltty-3.5.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.5.ebuild,v 1.2 2004/06/24 21:17:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.5.ebuild,v 1.3 2004/06/25 15:55:35 vapier Exp $
-IUSE="gpm"
-
-DESCRIPTION="BRLTTY is a background process (daemon) which provides access to the Linux/Unix console (when in text mode) for a blind person "
-HOMEPAGE="http://mielke.cc/brltty"
+DESCRIPTION="daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ~ppc64"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64"
+IUSE="gpm"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
gpm? ( >=sys-libs/gpm-1.20 )"
src_compile() {
- econf \
- `use_enable gpm` || die
+ econf `use_enable gpm` || die
make || die
}
diff --git a/app-accessibility/flite/flite-1.2-r1.ebuild b/app-accessibility/flite/flite-1.2-r1.ebuild
index b20e81cff2f5..dafa3dfbf10c 100644
--- a/app-accessibility/flite/flite-1.2-r1.ebuild
+++ b/app-accessibility/flite/flite-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2-r1.ebuild,v 1.5 2004/06/24 21:22:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2-r1.ebuild,v 1.6 2004/06/25 15:57:07 vapier Exp $
inherit eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc amd64"
IUSE="static"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S=${WORKDIR}/${P}-release
@@ -30,8 +30,8 @@ src_unpack() {
}
src_compile() {
- local myconf;
- if ! use static; then
+ local myconf
+ if ! use static ; then
myconf="${myconf} --enable-shared"
fi
myconf="${myconf} --with-vox=cmu_us_kal16"
@@ -41,11 +41,11 @@ src_compile() {
emake -j1 || die "Failed compilation"
}
-src_install () {
- dobin bin/*
+src_install() {
+ dobin bin/* || die
dodoc ACKNOWLEDGEMENTS README
- if use static; then
+ if use static ; then
dolib.a lib/*.a
else
for lib in lib/*.so*; do
diff --git a/app-accessibility/flite/flite-1.2.ebuild b/app-accessibility/flite/flite-1.2.ebuild
index 621bd825fb6c..4a751febf267 100644
--- a/app-accessibility/flite/flite-1.2.ebuild
+++ b/app-accessibility/flite/flite-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2.ebuild,v 1.7 2004/06/24 21:22:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2.ebuild,v 1.8 2004/06/25 15:57:07 vapier Exp $
DESCRIPTION="Flite text to speech engine"
HOMEPAGE="http://www.speech.cs.cmu.edu/flite/index.html"
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
IUSE="static"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S=${WORKDIR}/${P}-release
@@ -26,8 +26,8 @@ src_unpack() {
}
src_compile() {
- local myconf;
- if ! use static; then
+ local myconf
+ if ! use static ; then
myconf="${myconf} --enable-shared"
fi
@@ -36,11 +36,11 @@ src_compile() {
emake -j1 || die "Failed compilation"
}
-src_install () {
- dobin bin/*
+src_install() {
+ dobin bin/* || die
dodoc ACKNOWLEDGEMENTS README
- if use static; then
+ if use static ; then
dolib.a lib/*.a
else
for lib in lib/*.so*; do