summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/egroupware/ChangeLog9
-rw-r--r--dev-php/egroupware/Manifest5
-rw-r--r--dev-php/egroupware/egroupware-0.9.99.005.ebuild48
-rw-r--r--dev-php/egroupware/files/digest-egroupware-0.9.99.0051
4 files changed, 60 insertions, 3 deletions
diff --git a/dev-php/egroupware/ChangeLog b/dev-php/egroupware/ChangeLog
new file mode 100644
index 000000000000..f2207678e7ad
--- /dev/null
+++ b/dev-php/egroupware/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-php/phpgroupware
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/egroupware/ChangeLog,v 1.1 2003/10/10 16:21:23 mholzer Exp $
+
+*egroupware-0.9.99.005 (10 Oct 2003)
+
+ 10 Oct 2003; Martin Holzer <mholzer@gentoo.org>
+ egroupware-0.9.99.005.ebuild:
+ Initial Version.
diff --git a/dev-php/egroupware/Manifest b/dev-php/egroupware/Manifest
index 81b9dc72c21f..882a6908a6fd 100644
--- a/dev-php/egroupware/Manifest
+++ b/dev-php/egroupware/Manifest
@@ -1,4 +1,3 @@
-MD5 0e5948fd511f3234602540496ece4020 ChangeLog 1553
-MD5 982557cc6bc136285592411a3b4bc494 egroupware-0.9.99.005.ebuild 1428
-MD5 1dd9268509d0274661f43e45850a5875 files/digest-phpgroupware-0.9.14.006 77
+MD5 4a314e3727bdda9f858b94a1461142d2 ChangeLog 360
+MD5 c4e788f9f56e57fc70c205889d984885 egroupware-0.9.99.005.ebuild 1390
MD5 d35fc686f6bcbf76c0b80e0fbf3de53d files/digest-egroupware-0.9.99.005 77
diff --git a/dev-php/egroupware/egroupware-0.9.99.005.ebuild b/dev-php/egroupware/egroupware-0.9.99.005.ebuild
new file mode 100644
index 000000000000..dc621f359aa9
--- /dev/null
+++ b/dev-php/egroupware/egroupware-0.9.99.005.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/egroupware/egroupware-0.9.99.005.ebuild,v 1.1 2003/10/10 16:21:23 mholzer Exp $
+
+MY_P=eGroupWare-${PV}
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="Web-based GroupWare suite. It contains many modules"
+HOMEPAGE="http://www.eGroupWare.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old egroupware version first."
+ ewarn "phpGroupWare will be installed into ${HTTPD_ROOT}/phpgroupware"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install() {
+ dodir ${HTTPD_ROOT}/${PN}
+ cd ${WORKDIR}
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} egroupware
+ dohtml ${PN}/doc/en_US/html/admin/*.html
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at /usr/share/doc/${PF}/html/x62.html#AEN134 "
+ einfo "to complete the install. You need to add MySQL users and configure phpGroupWare"
+}
diff --git a/dev-php/egroupware/files/digest-egroupware-0.9.99.005 b/dev-php/egroupware/files/digest-egroupware-0.9.99.005
new file mode 100644
index 000000000000..ebb816c34bb2
--- /dev/null
+++ b/dev-php/egroupware/files/digest-egroupware-0.9.99.005
@@ -0,0 +1 @@
+MD5 c678035da873e70ee49782dc5789c749 eGroupWare-0.9.99.005-0.tar.bz2 6738808