summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/egroupware/egroupware-0.9.99.005.ebuild')
-rw-r--r--dev-php/egroupware/egroupware-0.9.99.005.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/egroupware/egroupware-0.9.99.005.ebuild b/dev-php/egroupware/egroupware-0.9.99.005.ebuild
new file mode 100644
index 000000000000..dc621f359aa9
--- /dev/null
+++ b/dev-php/egroupware/egroupware-0.9.99.005.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/egroupware/egroupware-0.9.99.005.ebuild,v 1.1 2003/10/10 16:21:23 mholzer Exp $
+
+MY_P=eGroupWare-${PV}
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="Web-based GroupWare suite. It contains many modules"
+HOMEPAGE="http://www.eGroupWare.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old egroupware version first."
+ ewarn "phpGroupWare will be installed into ${HTTPD_ROOT}/phpgroupware"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install() {
+ dodir ${HTTPD_ROOT}/${PN}
+ cd ${WORKDIR}
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} egroupware
+ dohtml ${PN}/doc/en_US/html/admin/*.html
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at /usr/share/doc/${PF}/html/x62.html#AEN134 "
+ einfo "to complete the install. You need to add MySQL users and configure phpGroupWare"
+}