summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngcrush/files/Makefile')
-rw-r--r--media-gfx/pngcrush/files/Makefile72
1 files changed, 5 insertions, 67 deletions
diff --git a/media-gfx/pngcrush/files/Makefile b/media-gfx/pngcrush/files/Makefile
index 22e7752ddefa..24e215b46b8f 100644
--- a/media-gfx/pngcrush/files/Makefile
+++ b/media-gfx/pngcrush/files/Makefile
@@ -1,69 +1,7 @@
-# Sample makefile for pngcrush using gcc and GNU make.
-# Glenn Randers-Pehrson
-# Last modified: 19 February 2005
-# Kapil Hari Paranjape
-# Last modified: 12 June 2008
-#
-# Invoke this makefile from a shell prompt in the usual way; for example:
-#
-# make -f Makefile
-#
-# This makefile builds a dynamically linked executable.
-
-# macros --------------------------------------------------------------------
-
-GAS_VERSION := $(shell as --version | sed -n -e's/GNU assembler (.*) //p')
-
-PNGINC = /usr/include
-
-CC ?= gcc
-RM = rm -f
-
+GAS_VERSION = $(shell as --version | sed -n -e's/GNU assembler (.*) //p')
CFLAGS += -I. -Wall
-
-O = .o
-E =
-
-# additional defines
-DEFINES = -DPNG_USE_PNGGCCRD -DPNG_iCCP_SUPPORTED \
+CPPFLAGS += -DPNG_USE_PNGGCCRD -DPNG_iCCP_SUPPORTED \
-DPNG_iTXt_SUPPORTED -DPNG_USE_GLOBAL_ARRAYS \
- -DGAS_VERSION="\"${GAS_VERSION}\"" \
-
-PNGCRUSH = pngcrush
-
-LIBS = -lpng -lz
-
-OBJS = pngcrush$(O)
-
-EXES = $(PNGCRUSH)$(E)
-
-
-# implicit make rules -------------------------------------------------------
-
-.c$(O): png.h cexcept.h $(ZHDR)
- $(CC) -c $(CFLAGS) $(DEFINES) $<
-
-
-# dependencies --------------------------------------------------------------
-
-all: $(EXES)
-
-png.h:
- ln -s $(PNGINC)/png.h png.h
-
-pngcrush$(O): pngcrush.c cexcept.h
- $(CC) -c $(CFLAGS) $(DEFINES) $<
-
-$(PNGCRUSH)$(E): $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
-
-# maintenance ---------------------------------------------------------------
-
-clean:
- $(RM) $(EXES) $(OBJS) png.h
-
-install:
- mkdir -p $(DESTDIR)/usr/bin/
- cp $(PNGCRUSH)$(E) $(DESTDIR)/usr/bin/
- chmod 0755 $(DESTDIR)/usr/bin/$(PNGCRUSH)$(E)
-
+ -DGAS_VERSION="\"${GAS_VERSION}\""
+LDLIBS += -lpng -lz
+all: pngcrush