summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pngcrush/ChangeLog10
-rw-r--r--media-gfx/pngcrush/files/Makefile72
-rw-r--r--media-gfx/pngcrush/pngcrush-1.6.15.ebuild34
3 files changed, 47 insertions, 69 deletions
diff --git a/media-gfx/pngcrush/ChangeLog b/media-gfx/pngcrush/ChangeLog
index 4c2f57916fb8..5f06774d651c 100644
--- a/media-gfx/pngcrush/ChangeLog
+++ b/media-gfx/pngcrush/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/pngcrush
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/ChangeLog,v 1.40 2009/03/14 11:27:22 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/ChangeLog,v 1.41 2009/04/02 23:22:40 vapier Exp $
+
+*pngcrush-1.6.15 (02 Apr 2009)
+
+ 02 Apr 2009; Mike Frysinger <vapier@gentoo.org> files/Makefile,
+ +pngcrush-1.6.15.ebuild:
+ Strip makefile down and version bump.
*pngcrush-1.6.14 (14 Mar 2009)
diff --git a/media-gfx/pngcrush/files/Makefile b/media-gfx/pngcrush/files/Makefile
index 22e7752ddefa..24e215b46b8f 100644
--- a/media-gfx/pngcrush/files/Makefile
+++ b/media-gfx/pngcrush/files/Makefile
@@ -1,69 +1,7 @@
-# Sample makefile for pngcrush using gcc and GNU make.
-# Glenn Randers-Pehrson
-# Last modified: 19 February 2005
-# Kapil Hari Paranjape
-# Last modified: 12 June 2008
-#
-# Invoke this makefile from a shell prompt in the usual way; for example:
-#
-# make -f Makefile
-#
-# This makefile builds a dynamically linked executable.
-
-# macros --------------------------------------------------------------------
-
-GAS_VERSION := $(shell as --version | sed -n -e's/GNU assembler (.*) //p')
-
-PNGINC = /usr/include
-
-CC ?= gcc
-RM = rm -f
-
+GAS_VERSION = $(shell as --version | sed -n -e's/GNU assembler (.*) //p')
CFLAGS += -I. -Wall
-
-O = .o
-E =
-
-# additional defines
-DEFINES = -DPNG_USE_PNGGCCRD -DPNG_iCCP_SUPPORTED \
+CPPFLAGS += -DPNG_USE_PNGGCCRD -DPNG_iCCP_SUPPORTED \
-DPNG_iTXt_SUPPORTED -DPNG_USE_GLOBAL_ARRAYS \
- -DGAS_VERSION="\"${GAS_VERSION}\"" \
-
-PNGCRUSH = pngcrush
-
-LIBS = -lpng -lz
-
-OBJS = pngcrush$(O)
-
-EXES = $(PNGCRUSH)$(E)
-
-
-# implicit make rules -------------------------------------------------------
-
-.c$(O): png.h cexcept.h $(ZHDR)
- $(CC) -c $(CFLAGS) $(DEFINES) $<
-
-
-# dependencies --------------------------------------------------------------
-
-all: $(EXES)
-
-png.h:
- ln -s $(PNGINC)/png.h png.h
-
-pngcrush$(O): pngcrush.c cexcept.h
- $(CC) -c $(CFLAGS) $(DEFINES) $<
-
-$(PNGCRUSH)$(E): $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
-
-# maintenance ---------------------------------------------------------------
-
-clean:
- $(RM) $(EXES) $(OBJS) png.h
-
-install:
- mkdir -p $(DESTDIR)/usr/bin/
- cp $(PNGCRUSH)$(E) $(DESTDIR)/usr/bin/
- chmod 0755 $(DESTDIR)/usr/bin/$(PNGCRUSH)$(E)
-
+ -DGAS_VERSION="\"${GAS_VERSION}\""
+LDLIBS += -lpng -lz
+all: pngcrush
diff --git a/media-gfx/pngcrush/pngcrush-1.6.15.ebuild b/media-gfx/pngcrush/pngcrush-1.6.15.ebuild
new file mode 100644
index 000000000000..c3b7f655042a
--- /dev/null
+++ b/media-gfx/pngcrush/pngcrush-1.6.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/pngcrush-1.6.15.ebuild,v 1.1 2009/04/02 23:22:40 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Portable Network Graphics (PNG) optimizing utility"
+HOMEPAGE="http://pmt.sourceforge.net/pngcrush"
+SRC_URI="mirror://sourceforge/pmt/${P}-nolib.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libpng-1.2.31"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-nolib"
+
+src_unpack() {
+ unpack ${A}
+ cp "${FILESDIR}"/Makefile "${S}" || die
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ dodoc *.txt
+}