summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dc-gui/ChangeLog9
-rw-r--r--net-p2p/dc-gui/dc-gui-0.58.ebuild40
-rw-r--r--net-p2p/dc-gui/files/digest-dc-gui-0.581
-rw-r--r--net-p2p/dctc/ChangeLog9
-rw-r--r--net-p2p/dctc/dctc-0.83.1.ebuild28
-rw-r--r--net-p2p/dctc/files/digest-dctc-0.83.11
6 files changed, 86 insertions, 2 deletions
diff --git a/net-p2p/dc-gui/ChangeLog b/net-p2p/dc-gui/ChangeLog
index b5542f120662..7adf52a9509a 100644
--- a/net-p2p/dc-gui/ChangeLog
+++ b/net-p2p/dc-gui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/dc-gui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-gui/ChangeLog,v 1.3 2002/06/25 11:20:29 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-gui/ChangeLog,v 1.4 2002/07/06 06:08:35 seemant Exp $
+
+*dc-gui-0.58 (5 Jul 2002)
+
+ 5 Jul 2002; Seemant Kulleen <seemant@gentoo.org> dc-gui-0.58.ebuild
+ files/digest-dc-gui-0.58 :
+
+ Version bump thanks to autobot@midsouth.rr.com (AutoBot) in bug #4253.
25 Jun 2002; Thilo Bangert <bangert@gentoo.org>:
diff --git a/net-p2p/dc-gui/dc-gui-0.58.ebuild b/net-p2p/dc-gui/dc-gui-0.58.ebuild
new file mode 100644
index 000000000000..880539462623
--- /dev/null
+++ b/net-p2p/dc-gui/dc-gui-0.58.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-gui/dc-gui-0.58.ebuild,v 1.1 2002/07/06 06:08:35 seemant Exp $
+
+S=${WORKDIR}/${P/-/_}
+DESCRIPTION="GUI for DCTC"
+SRC_URI="http://ac2i.tzo.com/dctc/${P/-/_}.tar.gz"
+HOMEPAGE="http://ac2i.tzo.com/dctc"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =dev-libs/glib-1.2*
+ =gnome-base/gnome-libs-1.4*
+ =sys-libs/db-3.2*
+ =x11-libs/gtk+-1.2*
+ >=net-p2p/dctc-0.82.0"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-gnome \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
diff --git a/net-p2p/dc-gui/files/digest-dc-gui-0.58 b/net-p2p/dc-gui/files/digest-dc-gui-0.58
new file mode 100644
index 000000000000..5ae4ea84fdb2
--- /dev/null
+++ b/net-p2p/dc-gui/files/digest-dc-gui-0.58
@@ -0,0 +1 @@
+MD5 2707c3c1bcd8f88694acf1e59bb2c16b dc_gui-0.58.tar.gz 386730
diff --git a/net-p2p/dctc/ChangeLog b/net-p2p/dctc/ChangeLog
index 66a455ead81a..f073fcc91dcf 100644
--- a/net-p2p/dctc/ChangeLog
+++ b/net-p2p/dctc/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for net-p2p/dctc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/ChangeLog,v 1.2 2002/06/25 11:12:27 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/ChangeLog,v 1.3 2002/07/06 06:04:26 seemant Exp $
+*dctc-0.83.1 (5 Jul 2002)
+
+ 5 Jul 2002; Seemant Kulleen <seemant@gentoo.org> dctc-0.83.1.ebuild
+ files/digest-dctc-0.83.1 :
+
+ Version bump thanks to autobot@midsouth.rr.com (AutoBot) in bug #4252.
+
*dctc-0.82.0 (4 Jun 2002)
4 Jun 2002; Seemant Kulleen <seemant@gentoo.org> dctc-0.82.0.ebuild
diff --git a/net-p2p/dctc/dctc-0.83.1.ebuild b/net-p2p/dctc/dctc-0.83.1.ebuild
new file mode 100644
index 000000000000..55127a295903
--- /dev/null
+++ b/net-p2p/dctc/dctc-0.83.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/dctc-0.83.1.ebuild,v 1.1 2002/07/06 06:04:26 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Direct Connect Text Client, almost famous file share program."
+SRC_URI="http://ac2i.tzo.com/dctc/${P}.tar.gz"
+HOMEPAGE="http://ac2i.tzo.com/dctc"
+SLOT="0"
+LICENSE="GPL-2"
+
+
+DEPEND="virtual/glibc
+ =dev-libs/glib-1.2*
+ =sys-libs/db-3.2*"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc -r Documentation
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN_BUGS NEWS README TODO
+}
diff --git a/net-p2p/dctc/files/digest-dctc-0.83.1 b/net-p2p/dctc/files/digest-dctc-0.83.1
new file mode 100644
index 000000000000..2c52aafdd6cb
--- /dev/null
+++ b/net-p2p/dctc/files/digest-dctc-0.83.1
@@ -0,0 +1 @@
+MD5 c42e2712dab06a3b6a7fd9800215c495 dctc-0.83.1.tar.gz 227166