aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-22 13:45:13 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-22 13:45:13 -0300
commitd919b39e27c3aa8bab2b6eab07d298b19034e12e (patch)
tree2b5e87e64ab9a41aed62035f7c00829d4499d464
parentremoved the implicit mask of live versions from the g_octave.ebuild module (diff)
downloadg-octave-d919b39e27c3aa8bab2b6eab07d298b19034e12e.tar.gz
g-octave-d919b39e27c3aa8bab2b6eab07d298b19034e12e.tar.bz2
g-octave-d919b39e27c3aa8bab2b6eab07d298b19034e12e.zip
using empty KEYWORDS for live versions
-rw-r--r--g_octave/ebuild.py2
-rwxr-xr-xscripts/g-octave16
2 files changed, 17 insertions, 1 deletions
diff --git a/g_octave/ebuild.py b/g_octave/ebuild.py
index 82a4f60..90eac4f 100644
--- a/g_octave/ebuild.py
+++ b/g_octave/ebuild.py
@@ -165,7 +165,7 @@ RDEPEND="${DEPEND}
'eutils': '',
'description': description,
'url': self.__desc.url,
- 'keywords': self.__keywords(accept_keywords),
+ 'keywords': self.__scm and '' or self.__keywords(accept_keywords),
'category': category,
'depend': '',
'rdepend': '',
diff --git a/scripts/g-octave b/scripts/g-octave
index 7d0d782..85bccf3 100755
--- a/scripts/g-octave
+++ b/scripts/g-octave
@@ -127,6 +127,22 @@ def main():
)
parser.add_option(
+ '--scm',
+ action = 'store_true',
+ dest = 'scm',
+ default = False,
+ help = 'enable the installation of the current live version of a package, if disabled on the configuration file'
+ )
+
+ parser.add_option(
+ '--no-scm',
+ action = 'store_true',
+ dest = 'no_scm',
+ default = False,
+ help = 'disable the installation of the current live version of a package, if enabled on the configuration file'
+ )
+
+ parser.add_option(
'-f', '--force',
action = 'store_true',
dest = 'force',