aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Lezcano <dlezcano@fr.ibm.com>2009-10-22 15:33:40 +0200
committerDaniel Lezcano <dlezcano@fr.ibm.com>2009-10-22 15:33:40 +0200
commit881450bbedbe722f4b92f03c3b2633fae2f8a13c (patch)
treed5cc651c4ce1af8507db69f92bc2da7e125e7f54 /configure.ac
parentremove test directory (diff)
downloadlxc-881450bbedbe722f4b92f03c3b2633fae2f8a13c.tar.gz
lxc-881450bbedbe722f4b92f03c3b2633fae2f8a13c.tar.bz2
lxc-881450bbedbe722f4b92f03c3b2633fae2f8a13c.zip
use config.h to define the lxcpath and co
Instead of passing the LXCPATH definition in the compiler command line, use configure.ac to define the value in the config.h file and include this file where it is needed. Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e68ed6..3acd0fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,11 @@ AS_AC_EXPAND(LOCALSTATEDIR, $localstatedir)
AS_AC_EXPAND(LXCPATH, "${localstatedir}/lib/lxc")
AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)")
+AH_TEMPLATE([LXCPATH], [lxc configuration repository])
+AH_TEMPLATE([LXCLIBEXECDIR], [lxc executable library path])
+AC_DEFINE_UNQUOTED(LXCPATH, "$LXCPATH")
+AC_DEFINE_UNQUOTED(LXCLIBEXECDIR, "$LIBEXECDIR")
+
AC_CHECK_HEADERS([linux/netlink.h linux/genetlink.h],
[],
AC_MSG_ERROR([netlink headers not found. Please install the linux kernel headers.]),