aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e68ed6..3acd0fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,11 @@ AS_AC_EXPAND(LOCALSTATEDIR, $localstatedir)
AS_AC_EXPAND(LXCPATH, "${localstatedir}/lib/lxc")
AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)")
+AH_TEMPLATE([LXCPATH], [lxc configuration repository])
+AH_TEMPLATE([LXCLIBEXECDIR], [lxc executable library path])
+AC_DEFINE_UNQUOTED(LXCPATH, "$LXCPATH")
+AC_DEFINE_UNQUOTED(LXCLIBEXECDIR, "$LIBEXECDIR")
+
AC_CHECK_HEADERS([linux/netlink.h linux/genetlink.h],
[],
AC_MSG_ERROR([netlink headers not found. Please install the linux kernel headers.]),