aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-07-12 11:44:16 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-19 14:35:07 +0200
commitacafe6e0405a9bcd41829884a04736f8d94e4d8c (patch)
tree55abe2482c151f7d393b32ac88ce8ccb990b89de
parentdev-python/pyfaidx: version bump 0.8.1.1 (diff)
downloadsci-acafe6e0405a9bcd41829884a04736f8d94e4d8c.tar.gz
sci-acafe6e0405a9bcd41829884a04736f8d94e4d8c.tar.bz2
sci-acafe6e0405a9bcd41829884a04736f8d94e4d8c.zip
sci-bioloy/gffutils: version bump 0.13; fix tests
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-biology/gffutils/Manifest2
-rw-r--r--sci-biology/gffutils/gffutils-0.11.1.ebuild42
-rw-r--r--sci-biology/gffutils/gffutils-0.13.ebuild32
-rw-r--r--sci-biology/gffutils/metadata.xml4
4 files changed, 33 insertions, 47 deletions
diff --git a/sci-biology/gffutils/Manifest b/sci-biology/gffutils/Manifest
index e8b006cbf..ca30cec83 100644
--- a/sci-biology/gffutils/Manifest
+++ b/sci-biology/gffutils/Manifest
@@ -1 +1 @@
-DIST gffutils-0.11.1.tar.gz 1646787 BLAKE2B 96e573cf366844c8a348aff062362aeaea1a46360c74ae75a2d8d730d37cd69f0e6c658d1d0f348ca8f8e8c49d9a7c923c52619341e8d2dabd92a329fb43b677 SHA512 1844e9d7626a800549def2ba09b4d97e60c8a1a0fce2da60d7841cf4c4347da50aea850e8c1a67b07de08d4e6cf737b0d5c2bf8eb5fc87900427866282e82bdb
+DIST gffutils-0.13.gh.tar.gz 1644910 BLAKE2B c8c4bc5d8a51e2e63d359bed8953730dc2d64ab04a96021fbaa891443f77c259886bcb81bab59eff622f23aeaed77c30bd1635b03761607ec562fa52d92ebea7 SHA512 617f84aeaa4d16b140083012c6b3656d5ea44a9a0619f8516e51379f92e9be85dff42e31c9ac2c3a77d7e3715f43c0106cd534317cc6ff4b6257fce56a1b635f
diff --git a/sci-biology/gffutils/gffutils-0.11.1.ebuild b/sci-biology/gffutils/gffutils-0.11.1.ebuild
deleted file mode 100644
index 8ee8fd4b5..000000000
--- a/sci-biology/gffutils/gffutils-0.11.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="GFF and GTF file manipulation and interconversion"
-HOMEPAGE="https://gffutils.readthedocs.io/en/latest/"
-SRC_URI="https://github.com/daler/gffutils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-# Nose tests no longer supported, migration on next release
-#RESTRICT="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/argh[${PYTHON_USEDEP}]
- dev-python/argcomplete[${PYTHON_USEDEP}]
- sci-biology/biopython[${PYTHON_USEDEP}]
- sci-biology/pybedtools[${PYTHON_USEDEP}]
- sci-biology/pyfaidx[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_prepare_all() {
- if use test; then
- sed -i -e "s:/tmp/gffutils-test:${T}:g" gffutils/test/test.py || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- nosetests -v -x --with-doctest -a '!slow' || die
-}
diff --git a/sci-biology/gffutils/gffutils-0.13.ebuild b/sci-biology/gffutils/gffutils-0.13.ebuild
new file mode 100644
index 000000000..fbd90b6d9
--- /dev/null
+++ b/sci-biology/gffutils/gffutils-0.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="GFF and GTF file manipulation and interconversion"
+HOMEPAGE="https://gffutils.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/daler/gffutils/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/pyfaidx[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+# https://github.com/daler/gffutils/issues/233 + cli not installed yet
+EPYTEST_DESELECT=(
+ gffutils/test/test_biopython_integration.py::test_roundtrip
+ gffutils/test/test_cli.py::test_issue_224
+)
+
+distutils_enable_tests pytest
diff --git a/sci-biology/gffutils/metadata.xml b/sci-biology/gffutils/metadata.xml
index c9fe23ced..dc2c60220 100644
--- a/sci-biology/gffutils/metadata.xml
+++ b/sci-biology/gffutils/metadata.xml
@@ -5,10 +5,6 @@
<email>mschu.dev@gmail.com</email>
<name>Michael Schubert</name>
</maintainer>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
<upstream>
<remote-id type="github">daler/gffutils</remote-id>
</upstream>