summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/qchartdiary
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/qchartdiary')
-rw-r--r--app-office/qchartdiary/Manifest1
-rw-r--r--app-office/qchartdiary/metadata.xml13
-rw-r--r--app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild37
3 files changed, 51 insertions, 0 deletions
diff --git a/app-office/qchartdiary/Manifest b/app-office/qchartdiary/Manifest
new file mode 100644
index 000000000000..e1be512e1207
--- /dev/null
+++ b/app-office/qchartdiary/Manifest
@@ -0,0 +1 @@
+DIST QChartDiary-0.6.4.1-src.tar.gz 72683 SHA256 03fc1001727de5207c43987af06cb1887cc6fc7ebdfda41697d2944a4b519742 SHA512 8f804daf4fc8f61c0f584f667ac109771976808ae03f1d5fa9debe4bee3ce4010906fcb337b0007bcf0058ec83f5f9381187155c42ba118915ae64857982fd89 WHIRLPOOL 7c3639835fcffe254963801d7a83f1bbdfc2f8e33e99315e43b139f6d45607df52a301f891b3bd94bcf66d4a7e3b1b2af8763fe4d960cf2f20dc5b772ea92f05
diff --git a/app-office/qchartdiary/metadata.xml b/app-office/qchartdiary/metadata.xml
new file mode 100644
index 000000000000..36afc87610fc
--- /dev/null
+++ b/app-office/qchartdiary/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">qchartdiary</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild b/app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild
new file mode 100644
index 000000000000..1fd0a9f91e94
--- /dev/null
+++ b/app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_PN="QChartDiary"
+
+DESCRIPTION="Free Qt4 diary/agenda application"
+HOMEPAGE="http://qt-apps.org/content/show.php?content=99294"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtsql:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+DOCS="AUTHORS CHANGELOG README"
+
+src_prepare() {
+ sed -i "s/doc\/${MY_PN}/doc\/${PF}/" ${MY_PN}.pro \
+ || die "failed to fix documentation path"
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${MY_PN} || die "dobin failed"
+}