summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/qchartdiary')
-rw-r--r--app-office/qchartdiary/Manifest1
-rw-r--r--app-office/qchartdiary/metadata.xml13
-rw-r--r--app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild37
3 files changed, 51 insertions, 0 deletions
diff --git a/app-office/qchartdiary/Manifest b/app-office/qchartdiary/Manifest
new file mode 100644
index 000000000000..e1be512e1207
--- /dev/null
+++ b/app-office/qchartdiary/Manifest
@@ -0,0 +1 @@
+DIST QChartDiary-0.6.4.1-src.tar.gz 72683 SHA256 03fc1001727de5207c43987af06cb1887cc6fc7ebdfda41697d2944a4b519742 SHA512 8f804daf4fc8f61c0f584f667ac109771976808ae03f1d5fa9debe4bee3ce4010906fcb337b0007bcf0058ec83f5f9381187155c42ba118915ae64857982fd89 WHIRLPOOL 7c3639835fcffe254963801d7a83f1bbdfc2f8e33e99315e43b139f6d45607df52a301f891b3bd94bcf66d4a7e3b1b2af8763fe4d960cf2f20dc5b772ea92f05
diff --git a/app-office/qchartdiary/metadata.xml b/app-office/qchartdiary/metadata.xml
new file mode 100644
index 000000000000..36afc87610fc
--- /dev/null
+++ b/app-office/qchartdiary/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">qchartdiary</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild b/app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild
new file mode 100644
index 000000000000..1fd0a9f91e94
--- /dev/null
+++ b/app-office/qchartdiary/qchartdiary-0.6.4.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_PN="QChartDiary"
+
+DESCRIPTION="Free Qt4 diary/agenda application"
+HOMEPAGE="http://qt-apps.org/content/show.php?content=99294"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtsql:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+DOCS="AUTHORS CHANGELOG README"
+
+src_prepare() {
+ sed -i "s/doc\/${MY_PN}/doc\/${PF}/" ${MY_PN}.pro \
+ || die "failed to fix documentation path"
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${MY_PN} || die "dobin failed"
+}