summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-03-29 21:34:40 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-03-30 02:19:15 +0200
commit71b3bcf7a5903bd8dc1072b699505ddc9dd461e2 (patch)
treeffb857d89bbbd2d303fa43c69530b445f995b479 /dev-php/awl/awl-0.62.ebuild
parentdev-php/PEAR-Crypt_GPG: bump to v1.6.5 (diff)
downloadgentoo-71b3bcf7a5903bd8dc1072b699505ddc9dd461e2.tar.gz
gentoo-71b3bcf7a5903bd8dc1072b699505ddc9dd461e2.tar.bz2
gentoo-71b3bcf7a5903bd8dc1072b699505ddc9dd461e2.zip
dev-php/awl: bump to v0.62
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/awl/awl-0.62.ebuild')
-rw-r--r--dev-php/awl/awl-0.62.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/awl/awl-0.62.ebuild b/dev-php/awl/awl-0.62.ebuild
new file mode 100644
index 000000000000..1972ef4d1108
--- /dev/null
+++ b/dev-php/awl/awl-0.62.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Andrew McMillan's Web Libraries"
+HOMEPAGE="https://gitlab.com/davical-project/awl"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+
+S="${WORKDIR}"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ phpunit --do-not-cache-result tests/ || die "test suite failed"
+}
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/php/${PN}
+ doins -r dba inc
+}