summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/awl/awl-0.62.ebuild')
-rw-r--r--dev-php/awl/awl-0.62.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/awl/awl-0.62.ebuild b/dev-php/awl/awl-0.62.ebuild
new file mode 100644
index 000000000000..1972ef4d1108
--- /dev/null
+++ b/dev-php/awl/awl-0.62.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Andrew McMillan's Web Libraries"
+HOMEPAGE="https://gitlab.com/davical-project/awl"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+
+S="${WORKDIR}"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ phpunit --do-not-cache-result tests/ || die "test suite failed"
+}
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/php/${PN}
+ doins -r dba inc
+}