summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-09 23:04:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-10 00:44:40 +0100
commit9ed31aada277b04315128f668469a23fcad1d84d (patch)
tree4763d9c9a3b47acd5f7aef8baee5dfdba865c230 /dev-python/openpyxl/openpyxl-3.0.7.ebuild
parentdev-python/cfn-python-lint: Bump to 0.47.0 (diff)
downloadgentoo-9ed31aada277b04315128f668469a23fcad1d84d.tar.gz
gentoo-9ed31aada277b04315128f668469a23fcad1d84d.tar.bz2
gentoo-9ed31aada277b04315128f668469a23fcad1d84d.zip
dev-python/openpyxl: Bump to 3.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl/openpyxl-3.0.7.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-3.0.7.ebuild b/dev-python/openpyxl/openpyxl-3.0.7.ebuild
new file mode 100644
index 000000000000..8ecd3bf3eba4
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+SRC_URI="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest