summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 16:31:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 17:23:32 +0200
commita2f99eed270342dba558c4dd7d0a9959cdc4639a (patch)
tree462b4fab44ff63897bedfebcd00f99a981d1a16b /dev-python/py-ubjson
parentdev-python/cbor2: Enable py3.11 (diff)
downloadgentoo-a2f99eed270342dba558c4dd7d0a9959cdc4639a.tar.gz
gentoo-a2f99eed270342dba558c4dd7d0a9959cdc4639a.tar.bz2
gentoo-a2f99eed270342dba558c4dd7d0a9959cdc4639a.zip
dev-python/py-ubjson: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/py-ubjson')
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..f3f5e5f2fdee
--- /dev/null
+++ b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Binary JSON encoder/decoder"
+HOMEPAGE="
+ https://github.com/Iotic-Labs/py-ubjson/
+ https://pypi.org/project/py-ubjson/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}