summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-04 17:11:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-04 17:21:46 +0300
commitadbf3f7426e8fe72c85aec000fae1b8d6ef9df11 (patch)
tree3a969bd2631aef5e83674ae242a839d3c03052b2 /dev-python/pygame
parentdev-python/pygame: add github upstream metadata (diff)
downloadgentoo-adbf3f7426e8fe72c85aec000fae1b8d6ef9df11.tar.gz
gentoo-adbf3f7426e8fe72c85aec000fae1b8d6ef9df11.tar.bz2
gentoo-adbf3f7426e8fe72c85aec000fae1b8d6ef9df11.zip
dev-python/pygame: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/pygame-2.0.1-r1.ebuild7
-rw-r--r--dev-python/pygame/pygame-9999.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/pygame/pygame-2.0.1-r1.ebuild b/dev-python/pygame/pygame-2.0.1-r1.ebuild
index 9fc9d5a9db70..b8c0c5f73b53 100644
--- a/dev-python/pygame/pygame-2.0.1-r1.ebuild
+++ b/dev-python/pygame/pygame-2.0.1-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -51,6 +52,10 @@ src_prepare() {
if ! use midi; then
rm test/midi_test.py || die
fi
+ # Fixed in next release
+ sed -e 's/++Py_REFCNT/Py_INCREF/' \
+ -e 's/--Py_REFCNT/Py_DECREF/' \
+ -i src_c/_sdl2/*.c || die
distutils-r1_src_prepare
}
diff --git a/dev-python/pygame/pygame-9999.ebuild b/dev-python/pygame/pygame-9999.ebuild
index 8d4ba88cd460..7207ee8e45a9 100644
--- a/dev-python/pygame/pygame-9999.ebuild
+++ b/dev-python/pygame/pygame-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 git-r3