summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 07:23:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 07:26:52 +0200
commit8a86ba0e639521efb16784e1f3e07484d9321717 (patch)
tree6cfb54a58c4406311bf6aa5309542a05f9130b14 /dev-python/pyxdg/pyxdg-0.28.ebuild
parentdev-python/django-cors-headers: Bump to 3.13.0 (diff)
downloadgentoo-8a86ba0e639521efb16784e1f3e07484d9321717.tar.gz
gentoo-8a86ba0e639521efb16784e1f3e07484d9321717.tar.bz2
gentoo-8a86ba0e639521efb16784e1f3e07484d9321717.zip
dev-python/pyxdg: Bump to 0.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.28.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.28.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.28.ebuild b/dev-python/pyxdg/pyxdg-0.28.ebuild
new file mode 100644
index 000000000000..3a32f58fe79a
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.28.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="${PN}-rel-${PV}"
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="
+ https://freedesktop.org/wiki/Software/pyxdg/
+ https://cgit.freedesktop.org/xdg/pyxdg/
+ https://pypi.org/project/pyxdg/
+"
+SRC_URI="
+ https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest