summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.28.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.28.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.28.ebuild b/dev-python/pyxdg/pyxdg-0.28.ebuild
new file mode 100644
index 000000000000..3a32f58fe79a
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.28.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="${PN}-rel-${PV}"
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="
+ https://freedesktop.org/wiki/Software/pyxdg/
+ https://cgit.freedesktop.org/xdg/pyxdg/
+ https://pypi.org/project/pyxdg/
+"
+SRC_URI="
+ https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest