summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-08 10:05:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-08 10:11:09 +0100
commitc14bebda9596bafcd915825bcb48a18d40140fa4 (patch)
treeece41ffd5c75938088b23f8392b66fa06d1ff2e4 /dev-python/stestr
parentdev-python/oslo-concurrency: Enable py3.12 (diff)
downloadgentoo-c14bebda9596bafcd915825bcb48a18d40140fa4.tar.gz
gentoo-c14bebda9596bafcd915825bcb48a18d40140fa4.tar.bz2
gentoo-c14bebda9596bafcd915825bcb48a18d40140fa4.zip
dev-python/stestr: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stestr')
-rw-r--r--dev-python/stestr/stestr-4.1.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/stestr/stestr-4.1.0.ebuild b/dev-python/stestr/stestr-4.1.0.ebuild
index ae45f1d2241a..facea035e081 100644
--- a/dev-python/stestr/stestr-4.1.0.ebuild
+++ b/dev-python/stestr/stestr-4.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -39,6 +39,7 @@ BDEPEND="
"
python_test() {
+ local -x PYTHONPATH="${BUILD_DIR}/install$(python_get_sitedir)"
stestr init || die
stestr run || die "Tests failed with ${EPYTHON}"
}