summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-17 06:41:14 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-17 06:41:14 +0200
commit38276902f572c9b52b330a7adf8818635f6d9585 (patch)
tree8214c030a2bd595e066c995d91d39d51d6e836fb /dev-ruby/pastel/pastel-0.7.3.ebuild
parentdev-ruby/equatable: add 0.6.0 (diff)
downloadgentoo-38276902f572c9b52b330a7adf8818635f6d9585.tar.gz
gentoo-38276902f572c9b52b330a7adf8818635f6d9585.tar.bz2
gentoo-38276902f572c9b52b330a7adf8818635f6d9585.zip
dev-ruby/pastel: add 0.7.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/pastel/pastel-0.7.3.ebuild')
-rw-r--r--dev-ruby/pastel/pastel-0.7.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/pastel/pastel-0.7.3.ebuild b/dev-ruby/pastel/pastel-0.7.3.ebuild
new file mode 100644
index 000000000000..e76bba5ba9fa
--- /dev/null
+++ b/dev-ruby/pastel/pastel-0.7.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal strings styling with intuitive and clean API"
+HOMEPAGE="https://github.com/piotrmurach/pastel"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/equatable-0.6:0
+ >=dev-ruby/tty-color-0.5:0
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}