summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2022-01-08 16:22:56 +0100
committerSven Wegener <swegener@gentoo.org>2022-01-08 16:31:43 +0100
commit33d7f0caedfd5c5dc0c00ab99da0daa5dfb21783 (patch)
treed637469a6a55bb0ee36e4c04ea09a4bb997cb355 /sci-electronics/pulseview
parentsci-electronics/sigrok-cli: Remove python USE flags (diff)
downloadgentoo-33d7f0caedfd5c5dc0c00ab99da0daa5dfb21783.tar.gz
gentoo-33d7f0caedfd5c5dc0c00ab99da0daa5dfb21783.tar.bz2
gentoo-33d7f0caedfd5c5dc0c00ab99da0daa5dfb21783.zip
sci-electronics/pulseview: Remove python USE flags
Selecting the python interpreter is completely done by libsigrokdecode. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sci-electronics/pulseview')
-rw-r--r--sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild (renamed from sci-electronics/pulseview/pulseview-0.4.2.ebuild)16
-rw-r--r--sci-electronics/pulseview/pulseview-9999.ebuild16
2 files changed, 6 insertions, 26 deletions
diff --git a/sci-electronics/pulseview/pulseview-0.4.2.ebuild b/sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild
index e96be770c575..a71826cfa065 100644
--- a/sci-electronics/pulseview/pulseview-0.4.2.ebuild
+++ b/sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit cmake python-single-r1 xdg-utils
+inherit cmake xdg-utils
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -21,7 +19,6 @@ HOMEPAGE="https://sigrok.org/wiki/PulseView"
LICENSE="GPL-3"
SLOT="0"
IUSE="+decode static"
-REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
dev-qt/linguist-tools:5
@@ -36,10 +33,7 @@ RDEPEND="
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
>=sci-libs/libsigrok-0.5.1:=[cxx]
- decode? (
- ${PYTHON_DEPS}
- >=sci-libs/libsigrokdecode-0.5.2:=[${PYTHON_SINGLE_USEDEP}]
- )
+ decode? ( >=sci-libs/libsigrokdecode-0.5.2:= )
"
DEPEND="${RDEPEND}"
@@ -50,10 +44,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.4.2-glib-2.68.patch
)
-pkg_setup() {
- use decode && python_setup
-}
-
src_prepare() {
cmake_src_prepare
cmake_comment_add_subdirectory manual
diff --git a/sci-electronics/pulseview/pulseview-9999.ebuild b/sci-electronics/pulseview/pulseview-9999.ebuild
index 1b2ea98c17f8..330e533dbf89 100644
--- a/sci-electronics/pulseview/pulseview-9999.ebuild
+++ b/sci-electronics/pulseview/pulseview-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit cmake python-single-r1 xdg-utils
+inherit cmake xdg-utils
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -21,7 +19,6 @@ HOMEPAGE="https://sigrok.org/wiki/PulseView"
LICENSE="GPL-3"
SLOT="0"
IUSE="+decode static"
-REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
dev-qt/linguist-tools:5
@@ -36,19 +33,12 @@ RDEPEND="
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
>=sci-libs/libsigrok-0.6.0:=[cxx]
- decode? (
- ${PYTHON_DEPS}
- >=sci-libs/libsigrokdecode-0.6.0:=[${PYTHON_SINGLE_USEDEP}]
- )
+ decode? ( >=sci-libs/libsigrokdecode-0.6.0:= )
"
DEPEND="${RDEPEND}"
DOCS=( HACKING NEWS README )
-pkg_setup() {
- use decode && python_setup
-}
-
src_prepare() {
cmake_src_prepare
cmake_comment_add_subdirectory manual