summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-wget')
-rw-r--r--app-emacs/emacs-wget/Manifest1
-rw-r--r--app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild27
-rw-r--r--app-emacs/emacs-wget/files/50emacs-wget-gentoo.el4
-rw-r--r--app-emacs/emacs-wget/metadata.xml5
4 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/emacs-wget/Manifest b/app-emacs/emacs-wget/Manifest
new file mode 100644
index 000000000000..96e441b39f0d
--- /dev/null
+++ b/app-emacs/emacs-wget/Manifest
@@ -0,0 +1 @@
+DIST emacs-wget-0.5.0.tar.gz 37074 SHA256 ce59516c15f9de0c637d033419605c58f4da2f5ba762f74a5911cc96b6df7e81 SHA512 32d322cda7435b901115cdc01ef6b6e84f2af7f686f7d6a89cc486523d9d8b9807903c4ee0fb945a4ff457720033523beb34037e29ef7c9cdf2a10c62b725d54 WHIRLPOOL 9ba21389535396d8cb79dabf263cc276a087644f52a5497b7bce30d26162598636fcff8fdec1a5e9b362afa4101501b8138ce8ce8d995857ac745b9ff12b0818
diff --git a/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild b/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..d01a43dca1f1
--- /dev/null
+++ b/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Wget interface for Emacs"
+HOMEPAGE="http://www.emacswiki.org/emacs/EmacsWget"
+SRC_URI="http://pop-club.hp.infoseek.co.jp/emacs/emacs-wget/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE="linguas_ja"
+
+RDEPEND=">=net-misc/wget-1.8.2"
+
+ELISP_REMOVE="lpath.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ dodoc ChangeLog README USAGE
+ use linguas_ja && dodoc README.ja USAGE.ja
+}
diff --git a/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el b/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el
new file mode 100644
index 000000000000..51afcaf6d4c1
--- /dev/null
+++ b/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'wget "wget" "wget interface for Emacs." t)
+(autoload 'wget-web-page "wget" "wget interface to download whole web page." t)
+(add-hook 'w3m-mode-hook (lambda () (require 'w3m-wget)))
diff --git a/app-emacs/emacs-wget/metadata.xml b/app-emacs/emacs-wget/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/emacs-wget/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>