summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-12-13 23:40:04 +0000
committerDamon Conway <kabau@gentoo.org>2001-12-13 23:40:04 +0000
commitd4e2b36bc8ce70e0a67be58b3ec9f1b25a9f1e5f (patch)
tree1fed1ea7d6fc996e1bd0db20f31679aab33b21c4 /app-shells/tcsh
parentAdded the splashimage line to the code listing for /boot/grub/menu.lst. (diff)
downloadhistorical-d4e2b36bc8ce70e0a67be58b3ec9f1b25a9f1e5f.tar.gz
historical-d4e2b36bc8ce70e0a67be58b3ec9f1b25a9f1e5f.tar.bz2
historical-d4e2b36bc8ce70e0a67be58b3ec9f1b25a9f1e5f.zip
Created tcsh-6.10-r2 and removed tcsh-6.10-r1. -r2 adds system startup
files to /etc. Also, the scripts support the env-update functionality.
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/files/csh.cshrc16
-rw-r--r--app-shells/tcsh/files/csh.login11
-rw-r--r--app-shells/tcsh/files/digest-tcsh-6.10-r21
-rw-r--r--app-shells/tcsh/tcsh-6.10-r2.ebuild43
4 files changed, 71 insertions, 0 deletions
diff --git a/app-shells/tcsh/files/csh.cshrc b/app-shells/tcsh/files/csh.cshrc
new file mode 100644
index 000000000000..faf757529a6e
--- /dev/null
+++ b/app-shells/tcsh/files/csh.cshrc
@@ -0,0 +1,16 @@
+# system-wide csh.cshrc
+
+if (-e /etc/csh.env) then
+ source /etc/csh.env
+endif
+
+if ($USER == "root") then
+ set path = (/bin /sbin /usr/bin /usr/sbin $ROOTPATH)
+ #077 would be more secure, but 022 is generally quite realistic
+ umask 022
+else
+ set path = (/bin /usr/bin $path)
+ umask 022
+endif
+
+unsetenv ROOTPATH
diff --git a/app-shells/tcsh/files/csh.login b/app-shells/tcsh/files/csh.login
new file mode 100644
index 000000000000..8b4b17750138
--- /dev/null
+++ b/app-shells/tcsh/files/csh.login
@@ -0,0 +1,11 @@
+alias d 'ls --color'
+alias ls 'ls --color=auto'
+alias ll 'ls --color -l'
+
+if ($USER == "root") then
+ set prompt = "%m %c # "
+else
+ set prompt = "%m %c $ "
+endif
+
+setenv EDITOR /usr/bin/nano
diff --git a/app-shells/tcsh/files/digest-tcsh-6.10-r2 b/app-shells/tcsh/files/digest-tcsh-6.10-r2
new file mode 100644
index 000000000000..0c3e07efe3f3
--- /dev/null
+++ b/app-shells/tcsh/files/digest-tcsh-6.10-r2
@@ -0,0 +1 @@
+MD5 f459c423074d85dfaa55439eb908a053 tcsh-6.10.tar.gz 667648
diff --git a/app-shells/tcsh/tcsh-6.10-r2.ebuild b/app-shells/tcsh/tcsh-6.10-r2.ebuild
new file mode 100644
index 000000000000..10aac65bd6aa
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.10-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r2.ebuild,v 1.1 2001/12/13 23:40:03 kabau Exp $
+
+S=${WORKDIR}/${P}.00
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+#ugh, astron.com doesn't support passive ftp... maybe another source?
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ perl? ( sys-devel/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/ --mandir=/usr/share/man --host=${CHOST}
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install install.man
+ if [ "`use perl`" ]
+ then
+ try perl tcsh.man2html
+ docinto html
+ dodoc tcsh.html/*.html
+ fi
+ dosym tcsh /bin/csh
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ insinto /etc
+ doins ${FILESDIR}/csh.cshrc ${FILESDIR}/csh.login
+}
+
+
+