summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitad69522f5e6b57d5350a46ebda16dbe091d0e4b6 (patch)
tree1580e46b57d69a004ab7bafb3f19590605890684 /games-fps/quake1
parentNew version 'n cleanup (diff)
downloadhistorical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.gz
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.bz2
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/quake1')
-rw-r--r--games-fps/quake1/ChangeLog8
-rw-r--r--games-fps/quake1/Manifest8
-rw-r--r--games-fps/quake1/files/digest-quake1-2.401
-rw-r--r--games-fps/quake1/files/fix-sys_printf.patch22
-rw-r--r--games-fps/quake1/files/makefile-gcc2-cflags.patch16
-rw-r--r--games-fps/quake1/files/makefile-gcc3-cflags.patch18
-rw-r--r--games-fps/quake1/files/makefile-path-fixes.patch36
-rw-r--r--games-fps/quake1/files/makefile-sedable.patch36
-rw-r--r--games-fps/quake1/quake1-2.40.ebuild79
9 files changed, 224 insertions, 0 deletions
diff --git a/games-fps/quake1/ChangeLog b/games-fps/quake1/ChangeLog
new file mode 100644
index 000000000000..181be509f409
--- /dev/null
+++ b/games-fps/quake1/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/quake1
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/ChangeLog,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+*quake1-2.40 (14 Jul 2003)
+
+ 14 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-fps/quake1/Manifest b/games-fps/quake1/Manifest
new file mode 100644
index 000000000000..883da77417af
--- /dev/null
+++ b/games-fps/quake1/Manifest
@@ -0,0 +1,8 @@
+MD5 fb9744193f1a0381afefbd8b5870890e ChangeLog 337
+MD5 53205ef49048876c04d1407a09d4b83e quake1-2.40.ebuild 2265
+MD5 1234946f709d4f661a2030a3b01fab6b files/digest-quake1-2.40 58
+MD5 08770c3708ba8384c402179f0c247ded files/makefile-gcc2-cflags.patch 815
+MD5 b47df8c86116df21eb3c75ff8d8142e6 files/makefile-gcc3-cflags.patch 878
+MD5 6a5b3a494d26b4f1b8d1063f9a0aa6e4 files/makefile-path-fixes.patch 1539
+MD5 6f4c55f7cf280c7c87e1e5a20934b813 files/makefile-sedable.patch 1064
+MD5 b9e1b8831a33b812643b9d5f3cab8cf2 files/fix-sys_printf.patch 666
diff --git a/games-fps/quake1/files/digest-quake1-2.40 b/games-fps/quake1/files/digest-quake1-2.40
new file mode 100644
index 000000000000..7f6e600a9e1d
--- /dev/null
+++ b/games-fps/quake1/files/digest-quake1-2.40
@@ -0,0 +1 @@
+MD5 70a802bd815a61a99e6c1c9a4eaeb0f2 q1source.zip 3211531
diff --git a/games-fps/quake1/files/fix-sys_printf.patch b/games-fps/quake1/files/fix-sys_printf.patch
new file mode 100644
index 000000000000..5b8e468ed521
--- /dev/null
+++ b/games-fps/quake1/files/fix-sys_printf.patch
@@ -0,0 +1,22 @@
+--- WinQuake/sys_linux.c.orig 2003-08-03 02:54:02.900882698 -0400
++++ WinQuake/sys_linux.c 2003-08-03 02:54:24.568968240 -0400
+@@ -86,7 +86,7 @@
+ void Sys_Printf (char *fmt, ...)
+ {
+ va_list argptr;
+- char text[1024];
++ char text[2048];
+ unsigned char *p;
+
+ va_start (argptr,fmt);
+--- QW/client/sys_linux.c.orig 2003-08-03 02:53:55.186276383 -0400
++++ QW/client/sys_linux.c 2003-08-03 02:54:18.706027413 -0400
+@@ -141,7 +141,7 @@
+ void Sys_Error (char *error, ...)
+ {
+ va_list argptr;
+- char string[1024];
++ char string[2048];
+
+ // change stdin to non blocking
+ fcntl (0, F_SETFL, fcntl (0, F_GETFL, 0) & ~FNDELAY);
diff --git a/games-fps/quake1/files/makefile-gcc2-cflags.patch b/games-fps/quake1/files/makefile-gcc2-cflags.patch
new file mode 100644
index 000000000000..3b2f87df4080
--- /dev/null
+++ b/games-fps/quake1/files/makefile-gcc2-cflags.patch
@@ -0,0 +1,16 @@
+--- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
++++ WinQuake/Makefile 2003-07-14 15:17:10.000000000 -0400
+@@ -39,3 +39,3 @@
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
++RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations
+--- QW/Makefile.orig 2003-07-14 15:13:12.000000000 -0400
++++ QW/Makefile 2003-07-14 15:15:41.000000000 -0400
+@@ -44,5 +44,5 @@
+ -fomit-frame-pointer -fexpensive-optimizations
+ else
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
++RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
+ -malign-jumps=2 -malign-functions=2
diff --git a/games-fps/quake1/files/makefile-gcc3-cflags.patch b/games-fps/quake1/files/makefile-gcc3-cflags.patch
new file mode 100644
index 000000000000..136c7a937fb6
--- /dev/null
+++ b/games-fps/quake1/files/makefile-gcc3-cflags.patch
@@ -0,0 +1,18 @@
+--- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
++++ WinQuake/Makefile 2003-07-14 15:17:10.000000000 -0400
+@@ -39,3 +39,3 @@
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
++RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations
+--- QW/Makefile.orig 2003-07-14 15:13:12.000000000 -0400
++++ QW/Makefile 2003-07-14 15:15:41.000000000 -0400
+@@ -45,5 +45,5 @@
+ else
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
+- -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
+- -malign-jumps=2 -malign-functions=2
++RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
++ -fomit-frame-pointer -fexpensive-optimizations -falign-loops=2 \
++ -falign-jumps=2 -falign-functions=2
+ endif
diff --git a/games-fps/quake1/files/makefile-path-fixes.patch b/games-fps/quake1/files/makefile-path-fixes.patch
new file mode 100644
index 000000000000..862234e55f86
--- /dev/null
+++ b/games-fps/quake1/files/makefile-path-fixes.patch
@@ -0,0 +1,36 @@
+--- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
++++ WinQuake/Makefile 2003-07-14 15:17:10.000000000 -0400
+@@ -27,4 +27,4 @@
+
+-MOUNT_DIR=/grog/Projects/WinQuake
+-MASTER_DIR=/grog/Projects/QuakeMaster
++MOUNT_DIR=../WinQuake
++MASTER_DIR=../QuakeMaster
+ MESA_DIR=/usr/local/src/Mesa-2.6
+@@ -35,3 +35,3 @@
+
+-EGCS=/usr/local/egcs-1.1.2/bin/gcc
++EGCS=gcc
+ CC=$(EGCS)
+@@ -47,5 +47,5 @@
+
+-MESAGLLDFLAGS=-L/usr/X11/lib -L/usr/local/lib -L$(MESA_DIR)/lib -lMesaGL -lglide2x -lX11 -lXext -ldl
++MESAGLLDFLAGS=-L/usr/X11R6/lib -L/usr/local/lib -L$(MESA_DIR)/lib -lMesaGL -lglide2x -lX11 -lXext -ldl
+ TDFXGLLDFLAGS=-L$(TDFXGL_DIR)/release$(ARCH)$(GLIBC) -l3dfxgl -lglide2x -ldl
+-GLLDFLAGS=-L/usr/X11/lib -L/usr/local/lib -lGL -lX11 -lXext -ldl -lXxf86dga -lXxf86vm -lm
++GLLDFLAGS=-L/usr/X11R6/lib -L/usr/local/lib -lGL -lX11 -lXext -ldl -lXxf86dga -lXxf86vm -lm
+ GLCFLAGS=-DGLQUAKE -I$(MESA_DIR)/include -I/usr/include/glide
+--- QW/Makefile.orig 2003-07-14 15:13:12.000000000 -0400
++++ QW/Makefile 2003-07-14 15:15:41.000000000 -0400
+@@ -29,3 +29,3 @@
+
+-MAINDIR=/grog/Projects/QW
++MAINDIR=../QW
+
+@@ -54,4 +54,4 @@
+ XLDFLAGS=-L/usr/X11R6/lib -lX11 -lXext
+-GL_SVGA_LDFLAGS=-L/usr/X11/lib -L/usr/local/src/Mesa-3.0/lib -lm -lMesaGL -lglide2x -lX11 -lXext -lvga
+-GL_X11_LDFLAGS=-L/usr/X11/lib -L/usr/local/src/Mesa-3.0/lib -lm -lGL -lX11 -lXext
++GL_SVGA_LDFLAGS=-L/usr/X11R6/lib -L/usr/local/src/Mesa-3.0/lib -lm -lMesaGL -lglide2x -lX11 -lXext -lvga
++GL_X11_LDFLAGS=-L/usr/X11R6/lib -L/usr/local/src/Mesa-3.0/lib -lm -lGL -lX11 -lXext
+
diff --git a/games-fps/quake1/files/makefile-sedable.patch b/games-fps/quake1/files/makefile-sedable.patch
new file mode 100644
index 000000000000..ab7533d96e62
--- /dev/null
+++ b/games-fps/quake1/files/makefile-sedable.patch
@@ -0,0 +1,36 @@
+--- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
++++ WinQuake/Makefile 2003-07-14 15:43:31.000000000 -0400
+@@ -64,11 +64,12 @@
+ # SETUP AND BUILD
+ #############################################################################
+
+-TARGETS=$(BUILDDIR)/bin/squake \
+- $(BUILDDIR)/bin/glquake \
+- $(BUILDDIR)/bin/glquake.glx \
+- $(BUILDDIR)/bin/glquake.3dfxgl \
+- $(BUILDDIR)/bin/quake.x11
++TARGETS=\
++ $(BUILDDIR)/bin/squake \
++ $(BUILDDIR)/bin/glquake \
++ $(BUILDDIR)/bin/glquake.glx \
++ $(BUILDDIR)/bin/glquake.3dfxgl \
++ $(BUILDDIR)/bin/quake.x11
+ # $(BUILDDIR)/bin/unixded
+
+ build_debug:
+--- QW/Makefile.orig 2003-07-14 15:13:12.000000000 -0400
++++ QW/Makefile 2003-07-14 15:44:00.000000000 -0400
+@@ -71,7 +71,12 @@
+ TARGETS=$(BUILDDIR)/qwsv
+ #$(BUILDDIR)/qwcl.x11
+ else
+-TARGETS=$(BUILDDIR)/qwsv $(BUILDDIR)/qwcl $(BUILDDIR)/qwcl.x11 $(BUILDDIR)/glqwcl $(BUILDDIR)/glqwcl.glx
++TARGETS=\
++ $(BUILDDIR)/qwsv \
++ $(BUILDDIR)/qwcl \
++ $(BUILDDIR)/qwcl.x11 \
++ $(BUILDDIR)/glqwcl \
++ $(BUILDDIR)/glqwcl.glx
+ endif
+
+ build_debug:
diff --git a/games-fps/quake1/quake1-2.40.ebuild b/games-fps/quake1/quake1-2.40.ebuild
new file mode 100644
index 000000000000..9fd6790773c5
--- /dev/null
+++ b/games-fps/quake1/quake1-2.40.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games eutils gcc
+
+DESCRIPTION="The original Quake engine straight from id !"
+HOMEPAGE="http://www.idsoftware.com/games/quake/quake/"
+SRC_URI="ftp://ftp.idsoftware.com/idstuff/source/q1source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="X opengl svga 3dfx"
+
+DEPEND="X? ( virtual/x11 )
+ opengl? ( virtual/opengl )
+ svga? ( media-libs/svgalib )
+ 3dfx? ( media-libs/glide-v3 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ echo
+ ewarn "You probably want app-games/quakeforge if you're"
+ ewarn "looking for a quake1 client ..."
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/fix-sys_printf.patch
+
+ mv WinQuake/Makefile{.linuxi386,}
+ mv QW/Makefile{.Linux,}
+
+ epatch ${FILESDIR}/makefile-path-fixes.patch
+
+ [ `gcc-major-version` -eq 3 ] \
+ && epatch ${FILESDIR}/makefile-gcc3-cflags.patch \
+ || epatch ${FILESDIR}/makefile-gcc2-cflags.patch
+ sed -i "s:GENTOO_CFLAGS:${CFLAGS} -DGL_EXT_SHARED=1:" {WinQuake,QW}/Makefile
+ cp QW/client/glquake.h{,.orig}
+ (echo "#define APIENTRY";cat QW/client/glquake.h.orig) > QW/client/glquake.h
+
+ epatch ${FILESDIR}/makefile-sedable.patch
+ if [ ! `use 3dfx` ] ; then
+ sed -i 's:^ $(BUILDDIR)/bin/glquake ::' WinQuake/Makefile
+ sed -i 's:^ $(BUILDDIR)/bin/glquake.3dfxgl ::' WinQuake/Makefile
+ sed -i 's:^ $(BUILDDIR)/glqwcl ::' QW/Makefile
+ fi
+ if [ ! `use X` ] ; then
+ sed -i 's:^ $(BUILDDIR)/bin/quake.x11 ::' WinQuake/Makefile
+ sed -i 's:^ $(BUILDDIR)/qwcl.x11 ::' QW/Makefile
+ fi
+ if [ ! `use opengl` ] ; then
+ sed -i 's:^ $(BUILDDIR)/bin/quake.glx ::' WinQuake/Makefile
+ sed -i 's:^ $(BUILDDIR)/glqwcl.glx ::' QW/Makefile
+ fi
+ if [ ! `use svga` ] ; then
+ sed -i 's:^ $(BUILDDIR)/bin/squake ::' WinQuake/Makefile
+ sed -i 's:^ $(BUILDDIR)/qwcl ::' QW/Makefile
+ fi
+}
+
+src_compile() {
+ cd ${S}/WinQuake
+ make build_release || die "failed to build WinQuake"
+ cd ${S}/QW
+ make build_release || die "failed to build QW"
+}
+
+src_install() {
+ dogamesbin WinQuake/release*/bin/*
+ dogamesbin QW/release*/*qw*
+ dodoc readme.txt {WinQuake,QW}/*.txt
+ prepgamesdirs
+}