summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-07 07:26:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-07 07:26:05 +0000
commit61f68a9681558c07d9408d268788047bf439334b (patch)
treea934813802d43f92d261ff08af3328aa3cddaa75 /sys-kernel/compaq-sources
parentuse sed -i; sed in unpack; error message for emake; Readme.txt, not Readme (diff)
downloadhistorical-61f68a9681558c07d9408d268788047bf439334b.tar.gz
historical-61f68a9681558c07d9408d268788047bf439334b.tar.bz2
historical-61f68a9681558c07d9408d268788047bf439334b.zip
repoman: trim trailing whitespace
Diffstat (limited to 'sys-kernel/compaq-sources')
-rw-r--r--sys-kernel/compaq-sources/Manifest2
-rw-r--r--sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild24
2 files changed, 13 insertions, 13 deletions
diff --git a/sys-kernel/compaq-sources/Manifest b/sys-kernel/compaq-sources/Manifest
index 8a765dc9437b..2126be02cc0e 100644
--- a/sys-kernel/compaq-sources/Manifest
+++ b/sys-kernel/compaq-sources/Manifest
@@ -1,4 +1,4 @@
-MD5 08752cd7ae94c88a1e534752c225f300 compaq-sources-2.4.9.32.7.ebuild 2419
MD5 8e85daaa5bd9b2f1156e7f625c310672 ChangeLog 406
+MD5 b96c7e5fc11cec67f2157c30263e2732 compaq-sources-2.4.9.32.7.ebuild 2410
MD5 fa89a9407fb524aa495fff27051ef881 metadata.xml 684
MD5 0d92b769cd5933ba7bc76182379575a9 files/digest-compaq-sources-2.4.9.32.7 80
diff --git a/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild b/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild
index 568f75e6aa1f..708e3c181dad 100644
--- a/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild
+++ b/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild,v 1.1 2003/05/13 18:49:07 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild,v 1.2 2003/09/07 07:26:00 msterret Exp $
ETYPE="sources"
inherit kernel
@@ -15,41 +15,41 @@ S=${WORKDIR}/linux-${KV}
# -taviso <taviso@gentoo.org>
#
-DEPEND="${DEPEND}
+DEPEND="${DEPEND}
app-arch/rpm2targz
>=sys-apps/sed-4"
REDPEND=""
DESCRIPTION="Kernel from the Compaq Distribution of Red Hat Linux (ALPHA)."
SRC_URI="ftp://ftp2.compaq.com/pub/linux/RedHat/7.2-alpha/updates/rpms/alpha/kernel-source-${KV}.alpha.rpm"
-HOMEPAGE="http://www.kernel.org/ http://www.redhat.com/ http://www.support.compaq.com/alpha-tools/redhat/"
+HOMEPAGE="http://www.kernel.org/ http://www.redhat.com/ http://www.support.compaq.com/alpha-tools/redhat/"
KEYWORDS="-* ~alpha"
SLOT="${KV}"
src_unpack() {
local kernel_rpm="kernel-source-${KV}.alpha.rpm"
cd ${WORKDIR}
-
+
ebegin "Unpacking Distribution RPM..."
-
+
# agriffis' fast+efficient rpm extraction method from
# the dev-lang/ccc ebuild.
- #
+ #
i=${DISTDIR}/${kernel_rpm}
dd ibs=`rpmoffset < ${i}` skip=1 if=$i 2>/dev/null \
| gzip -dc | cpio -idmu 2>/dev/null \
&& find usr -type d -print0 | xargs -0 chmod a+rx
eend ${?}
assert "Failed to extract ${kernel_rpm%.rpm}.tar.gz"
-
+
mv usr/src/linux-${KV} ${WORKDIR}
- cd ${S}
-
+ cd ${S}
+
# just fix a couple of minor issues...
sed -i 's#include/linux/autoconf.h \(include/linux/version.h \\\)#\1#' Makefile
sed -i 's#\(extern\) \(unsigned long irq_err_count;\)#\1 volatile \2#' arch/alpha/kernel/irq_alpha.c
- sed -i 's#/DISCARD/ : { \*(.text.exit)#/DISCARD/ : {#' arch/alpha/vmlinux.lds.in
-
+ sed -i 's#/DISCARD/ : { \*(.text.exit)#/DISCARD/ : {#' arch/alpha/vmlinux.lds.in
+
# hand it over to the eclass...
kernel_universal_unpack
}
@@ -62,7 +62,7 @@ pkg_postinst () {
einfo "extensively tested, and used by many thousands. This kernel will include"
einfo "bugfixes and extended hardware support, and is probably the most widely"
einfo "used Linux kernel on the Alpha Platform today."
- einfo
+ einfo
ewarn "DO NOT Report issues with this kernel to Red Hat or Compaq, use"
ewarn "the Gentoo Linux bugzilla at http://bugs.gentoo.org/"
einfo