aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-11 11:43:59 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-11 11:43:59 -0400
commitec1a27bf626cb4274f1f2797b4ddeb0017e0112e (patch)
tree2dcd1b265d3dba253979ac90e4ab5ffd807ff9b1
parentebuild-test/patches: test that PATCHES is an array (diff)
downloadgen-b0rk-ec1a27bf626cb4274f1f2797b4ddeb0017e0112e.tar.gz
gen-b0rk-ec1a27bf626cb4274f1f2797b4ddeb0017e0112e.tar.bz2
gen-b0rk-ec1a27bf626cb4274f1f2797b4ddeb0017e0112e.zip
ebuild-test/minorsyn: split this into 4 packages
-rw-r--r--ebuild-test/minorsyn-deprecated/metadata.xml26
-rw-r--r--ebuild-test/minorsyn-deprecated/minorsyn-deprecated-0.ebuild20
-rw-r--r--ebuild-test/minorsyn-quoting/metadata.xml26
-rw-r--r--ebuild-test/minorsyn-quoting/minorsyn-quoting-0.ebuild39
-rw-r--r--ebuild-test/minorsyn-whitespace/metadata.xml26
-rw-r--r--ebuild-test/minorsyn-whitespace/minorsyn-whitespace-0.ebuild20
-rw-r--r--ebuild-test/minorsyn/minorsyn-0.ebuild17
7 files changed, 157 insertions, 17 deletions
diff --git a/ebuild-test/minorsyn-deprecated/metadata.xml b/ebuild-test/minorsyn-deprecated/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/minorsyn-deprecated/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/minorsyn-deprecated/minorsyn-deprecated-0.ebuild b/ebuild-test/minorsyn-deprecated/minorsyn-deprecated-0.ebuild
new file mode 100644
index 0000000..ccd0cfb
--- /dev/null
+++ b/ebuild-test/minorsyn-deprecated/minorsyn-deprecated-0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Minor syntax errors: deprecated functions"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ built_with_use foo
+ useq foo
+ hasq foo
+ : $(bindnow-flags)
+ preserve_old_lib foo
+}
diff --git a/ebuild-test/minorsyn-quoting/metadata.xml b/ebuild-test/minorsyn-quoting/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/minorsyn-quoting/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/minorsyn-quoting/minorsyn-quoting-0.ebuild b/ebuild-test/minorsyn-quoting/minorsyn-quoting-0.ebuild
new file mode 100644
index 0000000..3d9f828
--- /dev/null
+++ b/ebuild-test/minorsyn-quoting/minorsyn-quoting-0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Minor syntax errors: variable quoting"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_unpack() {
+ # A should never be quoted when passed to unpack
+ unpack "${A}"
+ # DISTDIR, WORKDIR, S should always be quoted
+ cp ${DISTDIR}/foo ${WORKDIR}/${P}
+ cd ${S}
+}
+
+src_prepare() {
+ # unquoted FILESDIR
+ eapply ${FILESDIR}/foo.patch
+}
+
+src_install() {
+ # unquoted ED
+ install foo ${ED}
+}
+
+pkg_postinst() {
+ # Variables do not need to be quoted in bash conditionals or for einfo.
+ # Variables do need to be quoted when passed to a real command.
+ if [[ ! -e ${EROOT}/foo ]]; then
+ touch ${EROOT}/foo
+ einfo installed foo to ${EROOT}
+ fi
+}
diff --git a/ebuild-test/minorsyn-whitespace/metadata.xml b/ebuild-test/minorsyn-whitespace/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/minorsyn-whitespace/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/minorsyn-whitespace/minorsyn-whitespace-0.ebuild b/ebuild-test/minorsyn-whitespace/minorsyn-whitespace-0.ebuild
new file mode 100644
index 0000000..570dc12
--- /dev/null
+++ b/ebuild-test/minorsyn-whitespace/minorsyn-whitespace-0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Minor syntax errors: whitespace"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ # leading space
+: trailing space
+# blank line in the middle
+
+
+# blank line at the end
+
diff --git a/ebuild-test/minorsyn/minorsyn-0.ebuild b/ebuild-test/minorsyn/minorsyn-0.ebuild
index 45c2609..b40812a 100644
--- a/ebuild-test/minorsyn/minorsyn-0.ebuild
+++ b/ebuild-test/minorsyn/minorsyn-0.ebuild
@@ -11,34 +11,17 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
- # leading space
-: trailing space
-: unquoted variable: ${S}
-
WANT_AUTOMAKE=latest
src_unpack() {
- # quoted ${A}
- unpack "${A}"
epatch
}
src_compile() {
econf
- built_with_use foo
- useq foo
- hasq foo
}
src_install() {
cd "${S}"
dodoc COPYING
- preserve_old_lib foo
- bindnow-flags foo
}
-
-# blank line in the middle
-
-
-# blank line at the end
-