aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael L <mike@michaellawrenceit.com>2018-09-01 00:32:00 -0500
committercnd <cynede@gentoo.org>2018-09-01 09:32:00 +0400
commit93edf5adc200506014c735a0d1e2e4796d5b7905 (patch)
tree6f030ee439285b2038b58d361a0c3a9a5ddcfb91 /dev-ruby
parentSplit extended flags like it done in gentoo tree. (#363) (diff)
downloadrust-93edf5adc200506014c735a0d1e2e4796d5b7905.tar.gz
rust-93edf5adc200506014c735a0d1e2e4796d5b7905.tar.bz2
rust-93edf5adc200506014c735a0d1e2e4796d5b7905.zip
few embeded os tools (#366)
* add helix A Bridge to rust and likewise rust to ruby. can also in time transpile ruby to rust by quick look... looks promising , as a faster metasp....somethin. makes my day.. or any other faster Sec-Ops toys.. * drop stub file via web. * drop helix demo deps from toml and gen ebuild
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/helix/Manifest4
-rw-r--r--dev-ruby/helix/helix-0.7.5.ebuild30
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/helix/Manifest b/dev-ruby/helix/Manifest
new file mode 100644
index 0000000..e5c66a7
--- /dev/null
+++ b/dev-ruby/helix/Manifest
@@ -0,0 +1,4 @@
+DIST cstr-macro-0.1.0.crate 640 SHA256 db53fddba18cdd35477a7213a3ef6acfbfa333c31b42ce019e544c4a1420a06f SHA512 ce10f82f02ca5d92b5087cf700d80f8c6df8ea62bf27dce81aee32e60ed9549c9e9a94c55e4eb8c9bb4b4cacdf208dafe93682f11d70252c295ed33845733733 WHIRLPOOL 0a74b5c28aec44d3990b3236ec5aadab0453c90826939b65360880e899970b9f3414ea56e0b6f11e0ab5e0332790d391f35402657ee05d6ac07ac7b41e0a30b1
+DIST helix-0.7.5.crate 12521 SHA256 49a017e3e798ad9386e0a0584e66fd6c04a80ccc1242eb8f689c62ce6f408240 SHA512 80849cf77304e979dd8c0c0d407084ccacb48d767b13414dac82fa54ef126ad166a0ed5ca6e785e5dc3cd94d5a3dd7a539eb673514f468d1a21376262996ac62 WHIRLPOOL ffdcbe4c75521c17d0c77a7e5f8a5ef17143940a76a83b58a40a58dd156035e5145d578a389c9d607e335c881fc760c95dd53999bd538d8875e907869383b1df
+DIST libc-0.2.43.crate 353810 SHA256 76e3a3ef172f1a0b9a9ff0dd1491ae5e6c948b94479a3021819ba7d860c8645d SHA512 d53b9fc460c68ed77b9c1a23c093c927125c0946b5231c343cf239e706d859af42efc2c7a4b95fecb46ab6ea9dd8473f7de308176a7dbab18e220246c5a7a8fe WHIRLPOOL b71a895d3f4f81ce73ee54134eaa2a0c8202fb4b73d6b44d881cb9414e178e811952bf25978301853d33af435e7a289468d902a7499396950295e1631e7f462d
+DIST libcruby-sys-0.7.5.crate 10116 SHA256 fef6028cdce0c8d55676fd1d66bb810facef8cade0dd71d28511d375e84da4c0 SHA512 a178932fe3b8c6883b62d9c274245578bf97abfe43cb74a608e855c0f8fd1515d16609cf602b442f4169706ed92a7dd5c08af8484c607bbc6561a93985f744ba WHIRLPOOL e21c0441afa2ddf26891e140c06d6c6d08cd0d389f8346a75bf1d6eb65f8177f05288a45b46c7db14c159aa72466565e977401370f3ec77403ebd836b9cf5bbd
diff --git a/dev-ruby/helix/helix-0.7.5.ebuild b/dev-ruby/helix/helix-0.7.5.ebuild
new file mode 100644
index 0000000..6784db4
--- /dev/null
+++ b/dev-ruby/helix/helix-0.7.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2017-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.1.5
+
+EAPI=6
+
+CRATES="
+cstr-macro-0.1.0
+helix-0.7.5
+libc-0.2.43
+libcruby-sys-0.7.5
+"
+
+inherit cargo
+
+DESCRIPTION="Embed Rust in your Ruby"
+HOMEPAGE="https://usehelix.com"
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+RESTRICT="mirror"
+LICENSE="ISC" # Update to proper Gentoo format
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# example crates for demos https://github.com/tildeio/helix/tree/master/examples/ are sources... each can have ebuids
+# more of a pain to add ?(examples and all the bleeping deps)