summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-02 00:41:27 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-02 02:53:34 -0400
commitd7d6f6d10ad511adcff5be696392129af1860770 (patch)
tree35163f4ef810e38ae727db9701ded7c6fa26faa3 /app-emulation
parentapp-emulation/wine-staging: USE=-debug -> global USE=strip in live (diff)
downloadgentoo-d7d6f6d10ad511adcff5be696392129af1860770.tar.gz
gentoo-d7d6f6d10ad511adcff5be696392129af1860770.tar.bz2
gentoo-d7d6f6d10ad511adcff5be696392129af1860770.zip
app-emulation/wine-vanilla: USE=-debug -> global USE=strip in live
Will update the old ebuilds eventually but given this triggers a rebuild with --changed-use (default enabled), will wait till a few bumps and maybe stable to give a chance for people to update and depclean old rather than unnecessarily rebuild all. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index a513b26e07bb..fa578d8607db 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -28,11 +28,11 @@ LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
IUSE="
+X +abi_x86_32 +abi_x86_64 +alsa capi crossdev-mingw cups dos
- llvm-libunwind debug custom-cflags +fontconfig +gecko gphoto2
- +gstreamer kerberos +mingw +mono netapi nls odbc opencl +opengl
- osmesa pcap perl pulseaudio samba scanner +sdl selinux smartcard
- +ssl +truetype udev udisks +unwind usb v4l +vulkan wayland
- +xcomposite xinerama"
+ llvm-libunwind custom-cflags +fontconfig +gecko gphoto2 +gstreamer
+ kerberos +mingw +mono netapi nls odbc opencl +opengl osmesa pcap
+ perl pulseaudio samba scanner +sdl selinux smartcard +ssl +strip
+ +truetype udev udisks +unwind usb v4l +vulkan wayland +xcomposite
+ xinerama"
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )" # bug #551124 for truetype
@@ -318,13 +318,17 @@ src_install() {
make_wrapper "${bin##*/}-${P#wine-}" "${bin#"${ED}"}"
done
- # don't let portage try to strip PE files with the wrong
- # strip executable and instead handle it here (saves ~120MB)
if use mingw; then
+ # don't let portage try to strip PE files with the wrong
+ # strip executable and instead handle it here (saves ~120MB)
dostrip -x ${WINE_PREFIX}/wine/{i386,x86_64}-windows
- use debug ||
+
+ if use strip; then
+ ebegin "Stripping Windows (PE) binaries"
find "${ED}"${WINE_PREFIX}/wine/*-windows -regex '.*\.\(a\|dll\|exe\)' \
- -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} + || die
+ -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} +
+ eend ${?} || die
+ fi
fi
dodoc ANNOUNCE AUTHORS README* documentation/README*