summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/lives/files/lives-2.2.8-config_doxygen.patch')
-rw-r--r--media-video/lives/files/lives-2.2.8-config_doxygen.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-video/lives/files/lives-2.2.8-config_doxygen.patch b/media-video/lives/files/lives-2.2.8-config_doxygen.patch
new file mode 100644
index 0000000..bd63b08
--- /dev/null
+++ b/media-video/lives/files/lives-2.2.8-config_doxygen.patch
@@ -0,0 +1,37 @@
+--- configure.ac.orig
++++ configure.ac
+@@ -147,21 +147,19 @@ fi
+
+ dnl Check for doxygen
+
+-AC_ARG_ENABLE( doxygen, [ --disable-doxygen Disable doxygen documentation.] , disable_doxygen=yes)
+-
+-if test "x$disable_doxygen" != "xyes" ; then
+-
+-AC_PATH_PROG(DOXYGEN, doxygen, no)
+-
+-if test x$DOXYGEN = xno; then
+- echo "Cannot find doxygen, will not build sourcecode documentation"
+-fi
+-
+-else
+- echo "Doxygen documentation disabled, not checking"
+- DOXYGEN=no
+-fi
+-
++AC_ARG_ENABLE( doxygen, [ --disable-doxygen Disable doxygen documentation.])
++
++AS_IF([test "x$enable_doxygen" != "xno"],
++[AC_PATH_PROG(DOXYGEN, doxygen, no)],
++[echo "Doxygen documentation disabled, not checking"
++DOXYGEN=no])
++
++AS_IF([test "x$DOXYGEN" = "xno"],
++[AS_IF(
++ [test "x$enable_doxygen" = "xyes"],[AC_MSG_ERROR([Cannot find doxygen, make sure it is installed in your PATH])],
++ [test "x$enable_doxygen" = "x"],[echo "Cannot find doxygen, will not build sourcecode documentation"])
++])
++
+ AM_CONDITIONAL(HAVE_DOXYGEN, test x$DOXYGEN != xno)
+
+