summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/lives/files')
-rw-r--r--media-video/lives/files/lives-1.6.0-fix-typo-callbacks.c.patch11
-rw-r--r--media-video/lives/files/lives-2.2.8-config_doxygen.patch (renamed from media-video/lives/files/lives-1.4.2-config_doxygen.patch)17
-rw-r--r--media-video/lives/files/lives-2.2.8-dont-modify-live-filesystem.patch11
3 files changed, 21 insertions, 18 deletions
diff --git a/media-video/lives/files/lives-1.6.0-fix-typo-callbacks.c.patch b/media-video/lives/files/lives-1.6.0-fix-typo-callbacks.c.patch
deleted file mode 100644
index 22a293c..0000000
--- a/media-video/lives/files/lives-1.6.0-fix-typo-callbacks.c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/callbacks.c.orig
-+++ src/callbacks.c
-@@ -3800,7 +3800,7 @@ on_record_perf_activate
- lives_alarm_clear(alarm_handle);
- frames_written=mainw->jackd->frames_written;
- seek_pos=mainw->jackd->seek_pos;
-- audio_ticks=mainw->pulsed->audio_ticks;
-+ audio_ticks=mainw->jackd->audio_ticks;
-
- jack_message.command=ASERVER_CMD_FILE_CLOSE;
- jack_message.data=NULL;
diff --git a/media-video/lives/files/lives-1.4.2-config_doxygen.patch b/media-video/lives/files/lives-2.2.8-config_doxygen.patch
index 022d303..bd63b08 100644
--- a/media-video/lives/files/lives-1.4.2-config_doxygen.patch
+++ b/media-video/lives/files/lives-2.2.8-config_doxygen.patch
@@ -1,12 +1,11 @@
---- configure.in.orig 2011-04-16 15:27:49.624886971 +0200
-+++ configure.in 2011-04-16 15:29:49.391886971 +0200
-@@ -116,20 +116,18 @@ fi
+--- configure.ac.orig
++++ configure.ac
+@@ -147,21 +147,19 @@ fi
- # Check for doxygen
+ dnl Check for doxygen
-AC_ARG_ENABLE( doxygen, [ --disable-doxygen Disable doxygen documentation.] , disable_doxygen=yes)
-+AC_ARG_ENABLE( doxygen, [ --disable-doxygen Disable doxygen documentation.])
-
+-
-if test "x$disable_doxygen" != "xyes" ; then
-
-AC_PATH_PROG(DOXYGEN, doxygen, no)
@@ -19,6 +18,9 @@
- echo "Doxygen documentation disabled, not checking"
- DOXYGEN=no
-fi
+-
++AC_ARG_ENABLE( doxygen, [ --disable-doxygen Disable doxygen documentation.])
++
+AS_IF([test "x$enable_doxygen" != "xno"],
+[AC_PATH_PROG(DOXYGEN, doxygen, no)],
+[echo "Doxygen documentation disabled, not checking"
@@ -29,6 +31,7 @@
+ [test "x$enable_doxygen" = "xyes"],[AC_MSG_ERROR([Cannot find doxygen, make sure it is installed in your PATH])],
+ [test "x$enable_doxygen" = "x"],[echo "Cannot find doxygen, will not build sourcecode documentation"])
+])
-
++
AM_CONDITIONAL(HAVE_DOXYGEN, test x$DOXYGEN != xno)
+
diff --git a/media-video/lives/files/lives-2.2.8-dont-modify-live-filesystem.patch b/media-video/lives/files/lives-2.2.8-dont-modify-live-filesystem.patch
new file mode 100644
index 0000000..5e3b068
--- /dev/null
+++ b/media-video/lives/files/lives-2.2.8-dont-modify-live-filesystem.patch
@@ -0,0 +1,11 @@
+--- libweed/Makefile.am.orig 2015-04-26 18:24:27.478211807 +0200
++++ libweed/Makefile.am 2015-04-26 18:24:48.410211572 +0200
+@@ -79,7 +79,7 @@ uninstall-local:
+
+
+ install-exec-hook:
+- rm -f /usr/lib/libweed*.la
++# rm -f /usr/lib/libweed*.la
+ ## The following is removed as it breaks packaging.
+ # /sbin/ldconfig
+