aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Broadhead <jamesbroadhead@gmail.com>2016-06-13 15:09:42 +0100
committerJames Broadhead <jamesbroadhead@gmail.com>2016-06-13 15:09:42 +0100
commit513395bc3b6464e12c8e73fb45d61fd006f35e36 (patch)
treed53200c7d47267e86820d33004732b11a16e27dc
parentgscan2pdf-1.2.7 (diff)
downloadjamesbroadhead-513395bc3b6464e12c8e73fb45d61fd006f35e36.tar.gz
jamesbroadhead-513395bc3b6464e12c8e73fb45d61fd006f35e36.tar.bz2
jamesbroadhead-513395bc3b6464e12c8e73fb45d61fd006f35e36.zip
Add app-editors/hexer
Since sunrise is going away, hosting this here https://bugs.gentoo.org/show_bug.cgi?id=313039
-rw-r--r--app-editors/hexer/Manifest2
-rw-r--r--app-editors/hexer/hexer-0.2.3.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/hexer/Manifest b/app-editors/hexer/Manifest
new file mode 100644
index 0000000..9bcc89b
--- /dev/null
+++ b/app-editors/hexer/Manifest
@@ -0,0 +1,2 @@
+DIST hexer-0.2.3.tar.gz 132116 SHA256 8fb09bd37d0afbbb070cc1663014e656b6ffff73747b952d93ffafe8761e552d SHA512 752f9c32f96f145d39336060437a5438e66d175489bd06eb619f2f136fb24f65c6e883c59b7541a3b52ced0be4e2fe268670da048e1cab6d61e8119a35af13c1 WHIRLPOOL 1a49e24498395dd46e4e12201d5425b8956bd34edcb1242ce95192c69bf7d40a11fb464287140b74851bd08fee229ac30c87bc3d699446441f0fa612d9238a06
+EBUILD hexer-0.2.3.ebuild 553 SHA256 d2206769698d7ac959c5aba5ce8b4adb99e00098b5d64096980d17f2506264f5 SHA512 e27761e0ceaec0f847fc62ba234fc998922b5712900e57cdf52cac44d5828fd507139b1b921fe23d921cca8cb8ee7e94cef12a4add2694061eab849dceabd80f WHIRLPOOL a5f9fb5dad3e385aa20c933c62cd1d72308db6d205eb3ac4daa92c98c78fed3b49defa79fee0dbc31908463128e1252bbdc07f7c55e17c0b40184bb08d110014
diff --git a/app-editors/hexer/hexer-0.2.3.ebuild b/app-editors/hexer/hexer-0.2.3.ebuild
new file mode 100644
index 0000000..3bebef4
--- /dev/null
+++ b/app-editors/hexer/hexer-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Hex editor with vi/ex-style user interface"
+HOMEPAGE="https://devel.ringlet.net/editors/hexer/"
+SRC_URI="https://devel.ringlet.net/editors/${PN}/${P}.tar.gz"
+
+LICENSE="hexer"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ${PN} bin2c
+ doman ${PN}.1
+ dodoc CHANGES README
+}